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Read Me
Web Searching: Fed up with Web searches that return loads of useless links? Using advanced search techniques, DEVONagent Pro takes on all those tedious search-and-review tasks, releasing you to concentrate on relevant results.
The DEVONagent Pro Advantage
[image: DEVONagent Pro Main Window]
Why DEVONagent Pro? 
Using advanced search techniques, DEVONagent Pro takes on all those tedious search-and-review tasks, releasing you to concentrate on relevant results. It assists you in
	[image: Icon]finding,
	[image: Icon]collecting, and
	[image: Icon]organizing

information from the Web or your DEVONthink Pro Office databases with a powerful and flexible search architecture. It also features a powerful, research-oriented web browser and simple built-in archive, and tightly integrates with DEVONthink.

What DEVONagent Pro Does for You 
	[image: Icon]Using both standard and specialized search engines, DEVONagent Pro intelligently summarizes the results -- fast!
	[image: Icon]Alternatively, DEVONagent Pro shows you an even larger number of search results using its unique graphical topic map.
	[image: Icon]DEVONagent Pro support your research while browsing the Web, e.g., by listing all objects such as images, linked documents, or outgoing links embedded into a viewed page.
	[image: Icon]DEVONagent Pro archives your search results with a single click or sends them to your DEVONthink database.
	[image: Icon]Instead of making you repeat actions, DEVONagent Pro performs those actions for you. Combine search sets, schedule searches, etc., to create your very own personalized search assistant.


Perfect Integration 
	[image: Icon]DEVONagent Pro integrates seamlessly with DEVONthink. With just one click, archive your search results, webpages, and other information grabbed from the Web to your DEVONthink database.
	[image: Icon]Select text in any application and use DEVONagent Pro's Services menu or a context menu item to search for it. The Menu Extra keeps DEVONagent Pro at your fingertips.
	[image: Icon]Use various actions, including notifications and AppleScript, to inform you of search results, then send them to either DEVONthink or the application of your choice to process them any way you wish.

Learn more about why you should use DEVONagent Pro, when you should use it, and how to run your first query: [Read more...]


System Requirements
Every Mac running macOS 11 Big Sur or later. In addition, a fast Internet connection is highly recommended.

Installing, Updating, Removing
Just move the DEVONagent Pro application package to the Applications folder or any other directory you have access to. Please note that OS X Services and the connection to DEVONthink work only for applications installed into one of the Applications folders. Also, a logout and login or restart is recommended after installation.
To update the software, choose DEVONagent Pro > Check For Updates in the Pro version. For the Lite or Express editions, or if you have trouble with the updater, manually download a new version from our Downloads, unzip the file, then simply copy the application from the disk image to your Applications folder, replacing the old version. Your archived searches will not be affected.
To remove DEVONagent Pro traces from your computer, trash the following files and folders (~ represents your home folder):
	[image: Icon]DEVONagent Pro
	[image: Icon]~/Library/Application Support/DEVONagent Pro
	[image: Icon]~/Library/Preferences/com.devon-technologies.agent.*
	[image: Icon]Any product-specific scripts in ~/Library/Application Scripts/ or ~/Library/Workflows/

Note:
 Depending the version of macOS you are using, some files may or may not be installed on your machine.

Trial Restrictions
Unregistered DEVONagent Pro runs for 60 hours of non-continuous runtime or 30 days, whichever is later. Close the app to stop the clock from ticking and re-open later to continue your evaluation. The menu extra is restricted to 100 searches until DEVONagent Pro is registered.

Version History
[image: ] New [image: ] Improved [image: ] Fixed [image: ] Removed [image: ] Known issue
Version 3.11.11 
This maintenance release includes many updates to plugins and search sets. These include several news outlets, e.g., Reuters, the PubMed site, the Latest Software search set, and even the plugin for our DEVONthink Server edition. Unfortunately, due to underlying changes on some sites, we had to remove some, notably Google-related ones. However, we now use multiple search engines for certain features, e.g., for the See Also inspector, to help ensure good results. Beyond that, we made many fixes and improvements to make our application more reliable and efficient.
	[image: ]Added Send anonymized analytics data to the Update settings. See our company's Privacy Policy page for more information on the data we may send.

	[image: ]Plugins updated: Medical > PubMed, Apple > MacUpdate, BBC News, RocketNews, Reuters, References > Philosophy, and World News Network.
	[image: ]The updated Web plugin improves support for Bing and now also uses Brave and Ecosia. We no longer use Google. (See the Removed section below.) We also improved filtering of Bing and Ecosia results.
	[image: ]We improved the compatibility of the DEVONthink Server plugin when using a self-signed certificate and also revised the description in the Window > Plugins & Scanners window.
	[image: ]We updated the Marketing, Mac > Latest News, and Latest Software search sets.
	[image: ]The See Also inspector in DEVONagent Pro browser windows now uses multiple search engines to improve reliability.
	[image: ]We improved the appearance of browser tab preview popovers in macOS Sequoia and later.
	[image: ]We made various cosmetic improvements to the user interface, e.g., title bar, text colors, and the Go > Workspaces > Edit panel.
	[image: ]The Search > Max. Download Size setting now defaults to 2048 KB.
	[image: ]We improved HTML parsing and conversion, e.g., while crawling pages.
	[image: ]Searching web pages added to the Sites tab of a search set or using the EngineSite key in plugins now uses multiple search engines.
	[image: ]We improved link filtering, especially from Brave Search results.
	[image: ]To prevent DEVONagent Pro from being detected as "unusual activity", we employ better dynamic throttling on Bing and Brave searches.
	[image: ]A revised user-agent improves compatibility with Bloomberg feeds.
	[image: ]You can now control the timeout of the download URL and download markdown/json from AppleScript commands more precisely with standard with timeout of x seconds end timeout handlers.

	[image: ]In rare cases, the context menu in web views could crash on macOS 15. Fixed.
	[image: ]Closing the preferences while a shortcut control was active could crash the application. Fixed.
	[image: ]On macOS Sequoia and later, the font displayed inconsistently in the popup menu of a search window's search field. Fixed.
	[image: ]In the Search Sets window, selected sets couldn't be renamed by clicking on them. Fixed.
	[image: ]The Web > Translate command could add an unnecessary request to the Download Manager. Fixed.
	[image: ]Pressing ⌃↩ didn't display the context menu reliably and could change the current selection. Fixed.
	[image: ]When using a weekly interval in a scheduled search set, the message about the next run reported the day before the chosen day, e.g., showing "Tuesday" when "Wednesday" was chosen. Fixed.
	[image: ]If the Download Manager had automatic purging disabled, removing downloaded items would incorrectly remove the downloaded files too. Fixed.
	[image: ]WebKit could crash when rendering the Consent Manager and Microsoft Clarity web pages. Fixed.
	[image: ]RSS and Atom feed articles only used the first listed author. Fixed.
	[image: ]The MacUpdate keywords search didn't work in browser windows. Fixed.
	[image: ]The Scripts > More Scripts command didn't select the Extras tab in the Support Assistant when running in French or German. Fixed.
	[image: ]The encoding parameter of the download markup from AppleScript command incorrectly listed ISO-Latin-1. The default is UTF-8. Fixed.
	[image: ]The registration panel didn't immediately report success or failure after the trial period expired. Fixed.

	[image: ]Due to the use of JavaScript to present search results and blocking third-party access, we removed: Google News, Google (PDF), Images & Video > Google Video and YouTube, Blogs > Google Blog Search, Patents > Google Patents, and US Patent Office.


Version 3.11.10 
This update tackles a major change by Google that was blocking access to its search results. We've also taken the opportunity to refresh the Yahoo! and Web plugins. Additionally, we've introduced a new plugin for the Brave Search engine and also included a few minor fixes and enhancements to improve your experience.
	[image: ]Brave Search plugin added.
	[image: ]Plugins updated: Google, Yahoo!, and Web. These updates also affected the Web search sets, e.g., Web > Deep.
	[image: ]Slashdot, Sciencemag, and arXiv are no longer excluded by default.
	[image: ]Dates not provided by server responses or HTML metadata are now more reliably detected.
	[image: ]Name editor dialogs can be made larger, e.g., when opened via AppleScript or using the Go > Workspaces > Add command.
	[image: ]Unquoted search terms weren't highlighted in a browser window. Fixed.
	[image: ]Qwant plugin removed.


Version 3.11.9 
In this latest release, we've enhanced the filtering and parsing of search results, making it easier to find what you're looking for. We've also refined the user interface to provide a smoother experience and improved compatibility with the latest version of macOS, Sequoia. In addition, we've fixed a number of problems, including eliminating a bug that could cause crashes during searches. As always, we've worked hard to enhance the overall performance and reliability of the application.
Note:
 Starting with version 3.11.9, DEVONagent Pro now requires macOS 11 Big Sur or later.
	[image: ]When manually checking for updates, the alert shows a Release Notes button if no updates are available.

	[image: ]Plugin updated: MacUpdate.
	[image: ]Search sets updated: Mac > Latest News.
	[image: ]Improved filtering of several inputs: non-article Wikipedia pages, Bing search results, and social media links, e.g., for tweeting or sharing.
	[image: ]Plugins having unspecified or unmatched tags or text ranges more reliably parse HTML pages.
	[image: ]Indexing, crawling, and converting HTML pages ignores more hidden elements.
	[image: ]Better updating of tabs and improved appearance.
	[image: ]The Download Manager supports VoiceOver.
	[image: ]Improved support for opening contextual menus via Control-Return on macOS Sequoia.
	[image: ]The URL commands x-devonagent://show-help and x-devonagent://showHelp support using anchors to open specific sections of the help, e.g., x-devonagent://showHelp#development.
	[image: ]Improved overall performance, also affecting, e.g., highlighting search occurrences.

	[image: ]Entering incorrect wildcards in a search could crash the application. Fixed.
	[image: ]Complex searches including wildcards, proximity operators, and parentheses didn't work correctly. Fixed.
	[image: ]On rare occasion, word occurrences and matches weren't retrieved correctly. Fixed.
	[image: ]The Archive window displayed an extraneous line. Fixed.
	[image: ]The View toolbar controls of Search windows didn't work correctly on the latest versions of macOS. Fixed.

	[image: ]Clinical Trials plugin.


Version 3.11.8 
Today's release adds a new plugin for the Ecosia search engine. It also includes updates to some plugins, search sets, and scanners. For more focused search results with Google and Web plugins, DEVONagent Pro uses verbatim searches, and proximity searches, e.g., using the NEAR operator, produce better results. Also, audio and video files no longer play automatically, speeding up browsing your results, and importing from Safari now allows adding even larger histories. And we made several fixes and improvements for better performance and reliability.
	[image: ]Plugin added: Ecosia.

	[image: ]Plugin updated: American Chemical Society.
	[image: ]Search sets updated: Marketing and Mac > Latest News.
	[image: ]Scanners updated: Wallpaper, Video, and Webcam.
	[image: ]The Web or Google-based plugins now use verbatim searches to provide more focused results.
	[image: ]Occurrences are more reliably matched and highlighted in the results of complex proximity queries.
	[image: ]Browsing search results is now faster as audio and video files will not automatically play when the page is loaded.
	[image: ]The text color has been changed to improve contrast, e.g., in the results and summaries.
	[image: ]Importing from Safari or using the History plugin support larger web histories.
	[image: ]The date of an item in the search results is included when adding it to DEVONthink.
	[image: ]When sending results to DEVONthink as formatted notes, the stylesheets in use are merged. This reduces the file size while more closely maintaining the appearance.
	[image: ]When using the Download window, invalid information regarding attachments in the web content is ignored.
	[image: ]The HTML and XML parser is now more reliable and performant.
	[image: ]HTML source now displays with better syntax coloring.
	[image: ]The authentication panel now looks the same from the AppleScript command, Download window, and a browser window.
	[image: ]Any numerical prefixes on the names of scripts and templates, e.g., 1., are ignored. This improves sorting the scripts and templates menus.
	[image: ]The name of scripts and templates can now be localized with a Contents > Resources > LocalizedNames.strings file inside the script or template package.
	[image: ]AppleScript and JavaScript for Automation (JXA) are more reliable.
	[image: ]A new hidden preference, DontSetFindPboard, disables using macOS' shared clipboard. This eliminates search terms used in DEVONagent Pro from being automatically used in other applications, e.g., EasyFind.
	[image: ]If DEVONagent Pro terminates abnormally, the last used browser windows and tabs as well as the Archive window aren't reopened. This alleviates potential crashes caused by content in one of those windows.

	[image: ]Pop-ups that automatically opened and closed could crash the application. Fixed.
	[image: ]Localized values for some parameters in a plugin via the Plugins & Scanners panel weren't retained when closing the editing window. Fixed.
	[image: ]The Video scanner could slow the display of items in the Objects inspector of a browser window. Fixed.
	[image: ]In the latest versions of macOS, the action button didn't appear correctly in the sidebar and inspectors in a DEVONagent Pro browser window. Also, the font size in the address bar and toolbar search field was incorrect. Fixed.
	[image: ]A stray vertical line could be seen in the Search Sets window. Fixed.
	[image: ]The localization of the Browser > DEVONthink Server plugin was incorrect. Fixed.
	[image: ]When using phrase-based proximity searches, e.g., "James Webb" NEAR "big bang", DEVONagent Pro didn't always match all occurrences. Using them in the results or the Archive window could return too many results. Fixed.
	[image: ]Using a NOT operator before parentheses wasn't properly provided to some search engines. Fixed.
	[image: ]The notification about invalid server certificates wouldn't accept user input. Fixed.
	[image: ]The description of the get items of feed AppleScript command was incorrect. Fixed.

	[image: ]Obsolete plugins: Neeva, StartPage.
	[image: ]Obsolete scripts: Post > To del.icio.us, Post > To Twitter.


Version 3.11.7 
Today's maintenance release brings three new plugins: Neeva, Caselaw, and IEEEXplore. Scripts and scanners, e.g., the Wallpaper scanner, now retrieve more image formats. In the DEVONagent Pro browser, the See Also inspector makes even better suggestions, and for RSS crawling you can use more feeds. For better search results, DEVONagent Pro handles filtering advertisements a bit more aggressively. And as always, we made fixes and again increased overall performance and reliability.
	[image: ]Added Neeva plug-in.
	[image: ]Added Legal > Caselaw plug-in to search the Caselaw Access Project. Please note this plug-in is very fast but also has site-imposed limitations.
	[image: ]Added Science > IEEEXplore plug-in. Please note this plug-in uses always express mode (no filtering) as the website requires JavaScript.

	[image: ]Saving and capturing web page images, e.g., via the context menu in a DEVONagent Pro browser window is now more reliable, retaining the original data and filename, when possible.
	[image: ]Linked and embedded images of web pages gathered by scripts and scanners, e.g., the Thumbnail Gallery, Webcam, and Wallpaper scanners now include WebP, JPEG, and JPEG2000 files. The retrieval of these items is also more reliable.
	[image: ]The See Also inspector in DEVONagent Pro browser windows now shows better results and more quickly.
	[image: ]Links in the results popovers in the menu extra look better.
	[image: ]Mastodon articles have better names automatically added.
	[image: ]Improved compatibility with even more RSS feeds.
	[image: ]Extended the Marketing search set and removed any obsolete entries.
	[image: ]More reliable and more aggressive advertisements filter.
	[image: ]Improved handling of invalid responses for attachments. They are skipped and not added to the Download Manager.
	[image: ]Improved percent escaping in links and URLs.
	[image: ]The user agent is now more broadly compatible with search engines.
	[image: ]Invalid URLs are now more consistently logged.
	[image: ]Updated the code for recording keyboard shortcuts. Please note that this will require setting user-defined shortcuts again.
	[image: ]A system-wide notification is shown every day and also every hour during the last 24 hours of the trial.
	[image: ]Improved overall reliability and performance.

	[image: ]In rare cases, exporting web pages as single-page PDF documents added a second page. Fixed.
	[image: ]Search and highlighting could sometimes fail, e.g, with greek characters. Fixed.
	[image: ]Images were sometimes saved with the wrong extension. Fixed.
	[image: ]The progress indicator of a DEVONagent Pro browser window's address bar wasn't accurate on the latest versions of macOS. Fixed.
	[image: ]Support Assistant resources couldn't always be installed. Fixed.
	[image: ]The alert and email in the case of outdated licenses wasn't correct. Fixed.

	[image: ]Removed the obsolete Web > Enable Java command and Preferences > Web > Java.


Version 3.11.6 ... 1.1 


Version 1.0 
Initial release.


License Agreement
PLEASE READ THIS LICENSE CAREFULLY BEFORE USING THIS SOFTWARE. BY USING THIS SOFTWARE, YOU ARE AGREEING TO BE BOUND BY THE TERMS OF THIS LICENSE AGREEMENT. IF YOU DO NOT AGREE TO THE TERMS OF THIS LICENSE, DELETE THE SOFTWARE OR RETURN THE SOFTWARE AND RELATED DOCUMENTATION TO DEVONTECHNOLOGIES, LLC.
1. License: The application and other components (sound and graphics) accompanying this License, whether on disk, in read only memory, or on any other media (the "Software"), and the related documentation are licensed to you by DEVONtechnologies. You own the disk on which the Software is recorded but DEVONtechnologies and/or DEVONtechnologies' Licensor(s) retain title to the Software and related documentation. This License allows you to non-simultaneously use the Software on multiple computers by the same person.
2. Restrictions: The Software contains copyrighted material, trade secrets and other proprietary material and in order to protect them you may not decompile, reverse engineer, disassemble or otherwise reduce the Software to a human-perceivable form. You may not sub-license, modify, rent, lease, or create derivative works based upon the Software in whole or in part. You may not distribute the Software in any form, including, but not limited to, electronic information service 	distribution, bulletin board distribution, and magnetic or optical medium distribution.
3. Disclaimer of Warranty on Software: You expressly acknowledge and agree that use of the Software is at your sole risk. The Software and related documentation is provided "AS IS" and without warranty of any kind.
4. Limitation of Liability: UNDER NO CIRCUMSTANCES INCLUDING NEGLIGENCE, SHALL DEVONTECHNOLOGIES BE LIABLE FOR ANY INCIDENTAL, SPECIAL OR CONSEQUENTIAL DAMAGES THAT RESULT FROM THE USE OR INABILITY TO USE THE SOFTWARE OR RELATED DOCUMENTATION. In no event shall DEVONtechnologies' total liability to you for all damages, losses and causes of action (whether in contract, tort (including negligence) or otherwise) exceed the amount paid by you for the Software.
Apple, Carbon, Classic, Cocoa, ColorSync, Darwin, OS X, QuickTime, Quartz and all other registered names are trademarks of their respective owners.

Credits
SMTPMailDelivery 
Dante Palacios
The SMTPMailDelivery library is used according to the MIT License.

Video JS 
Copyright © 2010 Zencoder, Inc.
The Video JS player is used according to the LGPL v3.


Getting Started
This chapter helps you get started with DEVONagent Pro. It explains why and when to use DEVONagent Pro, and gives you step-by-step instruction in how to run a first query.
Why use DEVONagent Pro?
This chapter helps you get started with DEVONagent Pro. It explains why and when to use DEVONagent Pro, and gives you step-by-step instruction in how to run a first query.
A common misconception is that DEVONagent Pro is a simple front-end to a search engine like Bing. If that's all you need, you can do that in your browser, DEVONagent Pro's browser, or its menu extra. But much more than that, DEVONagent Pro is a powerful Internet research assistant that takes over many of the tedious tasks in web searching.
When you start using DEVONagent Pro, you will likely notice searches take longer you're used to. You will also see it returns fewer results than your browser's search engine. Now imagine you hired an assistant and tasked them with doing an Internet search, combing through the results, and emailing you a summary of the useful links. DEVONagent Pro is your electronic assistant, downloading and assessing each page returned by a search, excluding advertisements, broken links, and irrelevant pages. When it completes its work, it produces a set of results, already filtered for you. While these tasks take more time and have a lower yield, the results you receive are more relevant. Also, these things are accomplished while you are busy with other things, improving your efficiency.
 Here are a few more things that separate DEVONagent Pro from just using a browser:
	[image: Icon]DEVONagent Pro supports a more advanced search syntax, including wildcards and proximity operators, e.g., problems NEAR (icloud sync*).
	[image: Icon]Scanners limit a search to pages with links to specific kinds of items. For example, Linked Documents only returns pages containing links to PDFs, Office documents, etc.
	[image: Icon]The search results, the Digest, or a report can be exported to a variety of formats. 
	[image: Icon]Searches can be saved to a separate file and loaded again in the future. And searches support the ability to append new results to those already gathered or ignore already archived pages when running a search again.
	[image: Icon]Search Sets allow querying and processing multiple resources with one configuration, including your own. Imagine searching DuckDuckGo, Ecosia, Wikipedia, and an RSS feed by selecting one search option and entering your search terms.
	[image: Icon]For repeated searches, set up a search set to run on a schedule. Archive or deliver the results in several ways, like receiving a summary via email.
	[image: Icon]DEVONagent Pro has a built-in WebKit-based browser so you can browse search results without leaving the application. It includes inspectors, access to scanner items like linked images or documents, and even views of the text or HTML source of the current web page.
	[image: Icon]From the browser to searches to processing matching pages, DEVONagent Pro has robust automation options unavailable in bespoke browsers.
	[image: Icon]You can use the built-in Archive to store curated references to the results of a search. View the text of a result, export it, or use it in a search set.
	[image: Icon]DEVONagent Pro is well-integrated with our document/information management application, DEVONthink, a powerful combination for many use cases.


When to use DEVONagent Pro?
Just like using your favorite search engine in a browser, DEVONagent Pro can do unfiltered searches. However, it isn't really intended for superficial or casual searches. Instead, it excels at deeper research and information gathering on specific topics. Here are a few ideal and not-so-ideal uses cases:
Use DEVONagent Pro for:
	[image: Icon]Querying multiple sites or search engines at once. This casts a wider net, searching more efficiently than opening multiple search windows. Note the built-in Web plugin and search sets simultaneously search multiple sites.
	[image: Icon]Searching for specific kinds of items like recipes, images, etc. using scanners or fine-tuning your search terms with advanced search operators and wildcards.
	[image: Icon]Running scheduled searches to monitor web pages and find new information. Stay up to date on your topics of interest automatically.
	[image: Icon]Loading saved searches to continue working with them. Review, process, or continue adding to your knowledge base at your leisure and convenience.
	[image: Icon]Examining textual connections in the content of matched pages. Drill down into the Digest's topics to discover new perspectives.
	[image: Icon]Exporting your results to share or use in other applications, including our own. Provide a rich text report of the results to your boss, colleague, or professor or add results to your DEVONthink database in a variety of formats.

Don't use DEVONagent Pro for:
	[image: Icon]Finding the webpage of company X or product Y.
	[image: Icon]Finding a very specific image or video.
	[image: Icon]Finding the definition for a word quickly, e.g., on Wikipedia.


DEVONagent Pro at a Glance
DEVONagent Pro hides complex functionality but makes it available when you need it. Here's a quick overview over the three main windows DEVONagent Pro uses and what window elements they offer.
Search Windows 
[image: The Search Window and its Elements]
You use search windows to enter your query (search term), start the search, and view the results. [Read more...]

Web Browser Windows 
[image: The Browser Window and its Elements]
You use web browser windows like any other web browser plus DEVONagent Pro's research-centric additions. [Read more...]

The Archive Window 
[image: The Archive Window and its Elements]
You use the archive to save search results and recall them later. [Read more...]


First steps with DEVONagent Pro
A first search: While DEVONagent Pro is a real power tool, searches do not need to be overly complex. Running a simple search using DEVONagent Pro is no more complicated than using Bing or DuckDuckGo.
	[image: Icon]Run a first search with a few simple steps

The next steps: Now that you know how to run a first search you can take the next steps unaided. Here are a few chapters for you to continue exploring DEVONagent Pro:
	[image: Icon]More common tasks
	[image: Icon]How to formulate a good query
	[image: Icon]How to create your own search sets
	[image: Icon]Customize DEVONagent Pro to your preferences
	[image: Icon]Create your own plugin if your search engine is not supported

Finally, DEVONagent Pro and the DEVONtechnologies website offer additional information and assistance:
	[image: Icon]Open the Support Assistant [special link, not enabled in ebook] for on-screen tutorials and regularly updated tips
	[image: Icon]Read the FAQ
	[image: Icon]Visit our lively user forum


Common Tasks
This chapter explains common tasks in DEVONagent Pro in a step-by-step way and points you to related topics.
How to find on the Internet
DEVONagent Pro's main objective is to find stuff on the Internet. It does so by sending a query (search term) to a selected set of search engines, e.g., Brave Search, collecting the results, analyzing them, and presenting them to you.
You tell DEVONagent Pro which search engines to use by selecting a plugin (contains instructions telling DEVONagent Pro how to communicate with a search engine) or search set (combinations of multiple plugins and other options). DEVONagent Pro comes with a large number of pre-fab plugins and search sets already installed. [Read more...]
[image: Finding information on the internet]
Step by step: You are trying to find information about the WikiLeaks disclosure of diplomatic cables.
	[image: Icon]Step 1: Open a new search window with File > New Search.
	[image: Icon]Step 2: Choose the search set you want to use in the magnifying glass [image: ] pop-up menu: Web (Fast)
	[image: Icon]Step 3: Enter your query (search term): wikileaks AND "diplomatic cables"
	[image: Icon]Step 4: Click Start.

[image: ]Click here [special link, not enabled in ebook] to make DEVONagent Pro run the search.
The best choice for a simple but comprehensive search is the pre-fab Web (Fast) search set. It is a multi-purpose search set that sends your query to the four major search engines: Bing, Brave Search , Ecosia, and Yahoo. Alternatively, you can choose plugins directly, e.g., the one for DuckDuckGo, in the magnifying glass pop-up menu.
DEVONagent Pro Advantage: You can use advanced Boolean operators. Doing so returns a pre-processed summary including extracted topics rather than just a simple list of links. In addition, DEVONagent Pro queries multiple search engines for you with one single click.
Next steps:
	[image: Icon]Fine tune your search with the Settings tab
	[image: Icon]Design a good query
	[image: Icon]Learn more about the advanced Boolean operators
	[image: Icon]Create your own search sets

Related topics:
	[image: Icon]The search window explained
	[image: Icon]List of pre-fab search sets
	[image: Icon]List of built-in search engine plugins


Deeper and broader searches
DEVONagent Pro can not only run queries on Ecosia and Bing, but comes with a large number of plugins that let it use less common search engines such as FindLaw, PubMed, or Highbeam.
Just choose the right plugin before you start your search from the magnifying glass [image: ] pop-up menu in the search field.
[image: Advanced searching]
Step by step: You are trying to find newspaper articles about the former German defence minister who had to resign because he copied large parts of his doctor thesis.
	[image: Icon]Step 1: Open a new search window with File > New Search.
	[image: Icon]Step 2: Choose the plugin to use in the magnifying glass [image: ] pop-up menu: References > Highbeam
	[image: Icon]Step 3: Enter your query (search term): "zu Guttenberg" plagiarism
	[image: Icon]Step 4: Click Start.

DEVONagent Pro sends the results to the Highbeam article search engine and presents you with the results.
[image: ] Click here [special link, not enabled in ebook] to make DEVONagent Pro run this search for you.
Next steps:
	[image: Icon]Design a good query
	[image: Icon]Learn more about the advanced Boolean operators

Related topics:
	[image: Icon]The search window explained
	[image: Icon]List of pre-fab search sets
	[image: Icon]List of built-in search engine plugins


How to customize DEVONagent Pro
Like most other Mac applications, DEVONagent Pro can be customized to better fit your needs. You adjust all of DEVONagent Pro's setting in its Preferences.
[image: Customize DEVONagent Pro]
Step by step: You want to exclude all links to eBay from the results.
	[image: Icon]Step 1: Open the Preferences, Search tab.
	[image: Icon]Step 2: Click into the Exclude Domains field.
	[image: Icon]Step 3: Add 'ebay.' (with the dot, but without the single quotes) to the list.

This filters all results with addresses containing the string 'ebay.'
Next steps:
	[image: Icon]Set the other preferences to your needs
	[image: Icon]Learn more about the other options in the DEVONagent Pro menu
	[image: Icon]Learn more about the other options in the action menu


How to set up a search set to crawl feeds
DEVONagent Pro not only queries search engines for you, it can also search on its own by "crawling" a specified list of webpages or news feeds and scanning them for the search term. This feature is handy when you have a number resources you want to watch, e.g., subject-specific news sites or feeds.
[image: Crawling feeds]
Step by step: You want to search one of the New York Times news feeds.
	[image: Icon]Step 1: [image: ] Click here [special link, not enabled in ebook] to open the Search Sets window. Open it manually using Window > Search Sets.
	[image: Icon]Step 2: Click the + button to create a new set. Name it, e.g., "New York Times".
	[image: Icon]Step 3: Switch to the Sites tab.
	[image: Icon]Step 4: [image: ] Click here [special link, not enabled in ebook] to open the New York Times RSS page in a new web browser window.
	[image: Icon]Step 5: Show the Inspectors tab using Web > Inspectors > Show and switch to the [image: ] tab.
	[image: Icon]Step 6: Copy the address of any RSS feed of interest by right-clicking it and choosing Copy from the context menu.
	[image: Icon]Step 7: Switch to the Search Sets window and paste it, e.g., by pressing ⌘V. or using Edit > Paste.

Repeat Steps 6 and 7 for any feeds that you want to add to your "New York Times" search set. You can now use this set like any other search set or plugin. Instead of querying any search engines, it will download the current state of all the feeds you have added and search them for occurences of your search term.
Next steps:
	[image: Icon]Run a first query
	[image: Icon]Design a good query
	[image: Icon]Learn more about the advanced Boolean operators
	[image: Icon]Run your search automatically

Related topics:
	[image: Icon]More about search sets


How to run a search automatically
Search sets are not only collections of rules about how to run a search, they are also the key to research automation in DEVONagent Pro. Add a default query to a search set and set its scheduler to make DEVONagent Pro run the search when you're not around, e.g., in the middle of the night, and execute chosen actions when the search is completed.
[image: Schedule a search run]
Step by step: You want to run the "Marketing" search set automatically once every day and send the results to you by email.
	[image: Icon]Step 1: [image: ] Click here [special link, not enabled in ebook] to have the Search Sets window opened and the "Marketing" search set selected for you.
	[image: Icon]Step 2: Switch to the Actions tab.
	[image: Icon]Step 3: Check Send mail to and enter your email address.
	[image: Icon]Step 4: Switch to the Schedule tab.
	[image: Icon]Step 5: Select Daily and set the time to, e.g., 9 a.m.

As the "Marketing" search set contains a default query on the General tab, you are done. Tomorrow morning at 9 a.m. DEVONagent Pro will automagically activate and run a search for the default query of the "Marketing" set. When it is finished, it will send a summary email to the specified email address.
Note:
 Your Mac needs to be on at the time the search set is scheduled to run. DEVONagent Pro is not able to wake your Mac up from sleep mode.
Next steps:
	[image: Icon]Learn more about actions
	[image: Icon]Learn more about the schedule options

Related topics:
	[image: Icon]Learn more about search sets


How to archive search results
After you have found good data on the Internet, it is likely you're only halfway to your desired outcome. You will want to keep the best results for future reference. For this reason, DEVONagent Pro comes with a built-in archive.
[image: Archiving a search]
Step by step: You want to archive all results of a search run.
	[image: Icon]Step 1: Run a search, e.g., with the Bing or Brave Search plugin.
	[image: Icon]Step 2: Choose Data > Add All To Archive.
	[image: Icon]Step 3: The results have been saved to the archive in a group named after your query.

Step by step: You want to archive results from a search run.
	[image: Icon]Step 1: Run a search, e.g. with the Bing or DuckDuckGo plugin.
	[image: Icon]Step 2: Switch to the Results tab, e.g., by pressing ⌘2.
	[image: Icon]Step 3: Select the results you want to archive.
	[image: Icon]Step 4: Choose Data > Add To Archive.
	[image: Icon]Step 5: The results have been saved to the archive in a group named after your query.

As an alternative to using Data > Add To Archive, Data > Add All To Archive, and Window > Archive, you can use the Add, Add All, and Archive toolbar icons of the search window. You may need to add the tools to the toolbar using View > Customize Toolbar.
Next steps:
	[image: Icon]Work with the archive

Related topics:
	[image: Icon]Adding results to DEVONthink


Queries
DEVONagent Pro provides powerful Boolean operators that allow users to precisely define a search query.
Queries can range from uncomplicated one-word search terms to complex multi-term queries. The rules for formulating queries are simple. By studying the rules and the Boolean operators, and with a little practice, users can 'tell' DEVONagent Pro exactly what to look for in a search.
Operators
Plugin/set selection 
To quickly select which plugin or search set DEVONagent Pro uses, start the query with the name of the plugin or search set or keyword followed by a colon.
Example: 
ecosia:devonthink

Case 
Terms are NOT case sensitive. You may use capitalization for proper names in a query, but DEVONagent Pro will ignore case in interpreting the query.

Precedence of terms 
Search terms and associated operators will be interpreted from left to right, except as modified by including portions of the query within parentheses.

Boolean operators 
The operators (often called Boolean operators) are words or symbols that establish logical rules for the terms in the search query. These are:
	[image: Icon]term1 AND term2: Contains term1 AND term2
	[image: Icon]term1 BUT term2: Contains term1 AND term2
	[image: Icon]term1 OR term2: Contains term1 OR term2
	[image: Icon]term1 XOR term2: Contains term1 or term2, but not both
	[image: Icon]term1 EOR term2: Contains term1 or term2, but not both
	[image: Icon]NOT term: Does not contain term
	[image: Icon]"term1": Contains the string term1, in exactly this form; uses fuzzy matching (e.g. "DEVON tech" matches also "DEVON-tech" or "DEVON++++tech"); accepts also the '*' operator, like 'BEFORE' but more precise.

Besides the classic Boolean operators, DEVONagent Pro features a number of operators usually only found in high-end databases. Use them as a replacement for AND and "quotes" to fine tune your query.
	[image: Icon]term1 NEAR term2: term1 occurs 10 words or less before or after term2
	[image: Icon]term1 NEAR/n term2: term1 occurs n or less words before or after term2
	[image: Icon]term1 BEFORE term2: term1 occurs before term2
	[image: Icon]term1 BEFORE/n term2: term1 occurs n or less words before term2
	[image: Icon]term1 NEXT term2: term1 occurs right before term2 (shortcut for BEFORE/1)
	[image: Icon]term1 NEXT/n term2: term 1 occurs n or less words before term2 (synonym for BEFORE/n)
	[image: Icon]term1 AFTER term2: term1 occurs after term2
	[image: Icon]term1 AFTER/n term2: term1 occurs n or less words after term2
	[image: Icon]term1 OPT term2: term1 is mandatory but term2 is optional. If term2 is also found the result is ranked higher.
	[image: Icon]~term1: Contains all words that begin or end with term1 (words containing term1 as a part of the word; depends on the queried search engine)

Note:
 See chapter Designing a Search Query for examples on how to use all these operators effectively.
For convenience, some of these operators can also be abbreviated using commonly used symbols:
	[image: Icon]AND: &, &&, +
	[image: Icon]OR: |, ||
	[image: Icon]XOR: ^, ^^
	[image: Icon]NOT: !, -

Note:
 The symbols above also are used by the Finder and Spotlight for searches. Enter the vertical ruler character for the OR operator by pressing ⇧7, ⇧\ or the appropriate keyboard combination for your keyboard layout.

Wildcards 
You can replace parts of words with wildcards matching one, multiple, or a range of characters:
	[image: Icon]?: Matches exactly one character.
	[image: Icon]*: Matches none, one, or multiple characters.
	[image: Icon][a-b]: Matches one character of the range 'a' through 'b'.
	[image: Icon][abc...] or [a|b|c|...]: Matches one character out of the given list of characters.
	[image: Icon][^...]: Matches one character that is not contained in the given list or range.

Note:
 Primary queries only support wildcards for sites, not for plugins or search engines.

Special rules 
To search for a word that is also the name of an operator, put the word inside quotation marks. The following example searches all four terms including the word "near":
Example: 
Beach "near" Los Angeles
Existing "site:<domain.com>" operators in primary queries are removed before matching to facilitate searching sites using the plugins or search sets using them.


Designing a search query
Writing your query as simply and as precisely as possible is the key to good search results. Following are some tips on how to write a good query.
Designing a good query 
Suppose you want to search for information about the mercury contamination of fish, and to focus on information released by or referring to the United States Environmental Protection Agency.
One problem with trying a simple AND search for a group of words is that the Environmental Protection Agency is referred to in various ways: Environmental Protection Agency, EPA and E.P.A.
If we tried the search string
Example: 
Environmental AND Protection AND Agency AND EPA AND E.P.A. AND fish AND mercury
we would probably get no results at all, as no single article would use all three terms for the environmental agency. And even if we were to get search results, we would get irrelevant results stemming from the terms environmental, protection and agency.
Here's a better way to design the query:
Example: 
("Environmental Protection Agency" OR EPA OR "E.P.A.")
which will pick up the variants in naming the agency in articles. Note that the two strings enclosed in quotation marks will now be treated as phrases. This reduces ambiguity. Also note the use of parentheses and the OR operator. We have now covered all three variants of common names used for the environmental agency. DEVONagent Pro will look for pages containing any one of those names.
Another potential ambiguity is created because it's possible that a large reference source might contain the word 'fish' in one section dealing with fishery resources, and contain the word 'mercury' in another section dealing with the history of barometers. We're simply not interested in that item. But if we use the NEAR operator between 'fish' and 'mercury' it's likely that we will get useful results, since this query places the space between the two terms at 10 words or less.
The refined query now becomes:
Example: 
("Environmental Protection Agency" OR EPA OR "E.P.A.") AND (fish NEAR mercury)
Notice that a second set of parentheses was used so that DEVONagent Pro doesn't wrongly interpret the query as requiring that both the environmental agency name and 'fish' must be NEAR 'mercury'. That confusion would be created if we wrote the query as:
Example: 
("Environmental Protection Agency" OR EPA OR "E.P.A." AND fish) NEAR mercury
Indeed, the refined search returned highly relevant pages. Of course, this search focused on literature about mercury contamination of fish in the United States. To change the geographical focus, one would simply replace the search strings in the first set of parentheses with, e.g., ("European Union" OR EU).

Improving your query 
Besides the typical Boolean operators AND, OR and NOT, DEVONagent Pro provides much more powerful NEAR, BEFORE and AFTER operators. Typically, only scientific high-end databases feature these operators, but DEVONagent Pro makes them available for Web research.
Note:
 Because almost none of the Web search engines support these operators, DEVONagent Pro sends the simpler AND query to them and applies the more sophisticated operators to the resulting pages.
All three operators connect two search terms closer together than AND, but not as tightly as the phrase operator (double quotes). With the additional distance parameter (e.g., NEAR/5) you can fine tune search results until you get only the results you are looking for.
Example: 
(steve NEAR/2 jobs) BEFORE (intel NEAR (imac OR macbook)) AND "San Francisco"
Connecting 'steve' and 'jobs' with NEAR/2 prevents getting result pages of some Steve looking for a job in his page footer. BEFORE makes sure it is a page that mentions Steve Jobs first, followed by the Intel Macs. Finally, the quotes around 'San Francisco' find only pages dealing with the city of San Francisco, not the city San Jose or a Brother Francisco mentioned elsewhere on the page.
Use the proprietary NEAR, BEFORE and AFTER operators when AND delivers too many results and quote marks delivers too few. Another example:
Example: 
document AND management AND mac
This query run with the Web (Fast) search set deliveres good results. But, many are not what we are looking for. Among good pages, it also presents the Wikipedia article about OS X because it contains all three words. But, of course, this article is not at all about document management on the Mac. We can refine this query, however, using the special DEVONagent Pro operators:
Example: 
document NEAR/2 management NEAR mac
This time, DEVONagent Pro returns fewer results, all of them dealing exactly with our search subject, document management for the Macintosh, because the three words must appear near each other in the text. In most cases, NEAR delivers more accurate results than AND.

First principle of a successful query 
Make the query precise and unambiguous. DEVONagent Pro's tools for clarifying your query are clear and simple and will help you obtain a high percentage of useful results.


Search sets
The quality of a query relies not only on the entered search term, it also relies heavily on the selected settings. Search sets are collections of all the parameters (settings) related to a search run. Use search sets to quickly tweak your settings, depending on what you are searching for on the Internet. This ensures that you always get the best results.
What are search sets?
Search sets basically are collections of all the parameters related to a search run:
	[image: Icon]A default query
	[image: Icon]Follow links settings
	[image: Icon]Filters and associated  scanners
	[image: Icon]Sites to scan or search
	[image: Icon]Pluginsto use
	[image: Icon]Actions to run when the search run is completed
	[image: Icon]A schedule

Using these settings, you can create search sets specifically tailored for your research needs. For example, you could create your own sets for:
	[image: Icon]Querying the arXiv and NASA sites for information related to astronomy or physics.
	[image: Icon]Looking for online articles related to DEVONtechnologies, as well as some Mac news sites, with the search scheduled every three hours and programmed to send a summary to your email address
	[image: Icon]Searching the most important medical databases, e.g., PubMed and FDA, in a single search run
	[image: Icon]Querying a number of general search engines like Bing, Brave Search, and Yahoo, but filtering out everything except pages with links to Office documents


Choosing a search set
Choosing the search set that you want to use for a search run is easy: Click the magnifying glass icon [image: ] in a DEVONagent Pro search field and choose a search set from the pop-up menu.
DEVONagent Pro comes with a number of predefined search sets, but you can easily create your own.

Creating and managing sets
[image: The search set editor and its elements]
Search sets can be edited, rearranged, exported, imported or deleted. DEVONagent Pro comes with a couple of useful predefined sets, which you can tweak to your needs. Or you can add new ones. Use Window > Search Sets to open the search set editor.
Note:
 Some of the settings can also be adjusted on-the-fly in the Settings and Advanced tabs.
The search set editor shows a list of all defined search sets and allows you to add new sets or delete the selected set using the + and - buttons, just like in other Mac applications. Rearrange your search sets using drag-and-drop, and single-click the name of any set to change its name. Add groups via the Action or context menu to organize your search sets.
Note:
 Some items can be dragged from one search set to another set, e.g., URLs from the sites tab.
To change the settings defined in a set, select it in the list and change the parameters in the right-hand pane. Switch between the areas, General, Advanced, Sites, Plugins, Actions, and Schedule by using the tabs above the parameter area.
Shortcut 
To create a new search set with exactly the same settings as the current search run, click the + button next to the Stop button in the search window. This creates a new search set with exactly the same settings including the query as the default query.

Action menu 
The Action menu, available from the gear button below the search set list, gives you access to additional commands. [Read more...]

Context menu 
The context menu gives you direct access to frequently used commands.
	[image: Icon]New Set: Creates a new, empty search set.
	[image: Icon]New Group: Creates a new group for organizing your search sets.
	[image: Icon]Duplicate: Duplicates the selected search set.
	[image: Icon]Delete: Deletes the selected search set. Attention: There is NO undo!
	[image: Icon]Import: Creates new search sets based on imported files. You can import previously exported sets, as well as OPML files, Camino, Firefox, Chrome, OmniWebor Safari bookmarks or the Safari history file. For OPML, bookmarks and history files, DEVONagent Pro creates a new search set with all URLs imported to the Sites list.
	[image: Icon]Export: Exports the selected search sets as separate files. Exported sets get the file name extension '.agentSet' and are XML/plist files. You can import them into DEVONagent Pro by double-clicking them in the Finder.



Sharing sets
You can easily share search sets with other DEVONagent Pro users. Export sets using either the context menu, the File > Sets menu command, or by simply dragging them e.g. to the Desktop. You can email exported sets and import them again into DEVONagent Pro simply by double-clicking them in the Finder.

General tab
On the General tab, you define the main parameters for this search set such as the default query, which filter and which scanner to use.
[image: Search Set Editor, General Tab]
Queries 
Default Query: Define a default query for this search set. DEVONagent Pro will automatically fill the query field with the default query when you select this search set. This is especially useful if you are using either the same query every time you use this search set or if you are running this set on a schedule.
Example: 
esa AND (mission NEAR "venus express")
Read more about formulating a query here: [Read more...]
Secondary Query: When you enter something here, the primary term (the one entered or the default query) is only used for querying the search engines,  not for accepting or rejecting pages. Without a secondary query, DEVONagent Pro uses the primary query for both querying search engines and post-filtering results.
You can use secondary queries for different terms for querying the search engines and accepting/rejecting pages. Although the primary query is restricted to 10 words, the secondary query is not restricted.
Example: 
Use the asterisk '*' as your default query to match everything, e.g, when scanning a list of websites or Atom/RSS/JSON feeds; this option is not applicable with search engine plugins, only with the Sites list. To accept all pages delivered by a primary query, use the asterisk '*' as the secondary query.

Follow links 
These options tell DEVONagent Pro to follow promising links on HTML pages and in news feeds. Links are considered 'promising' if they match the entered or default query. If you enter an additional query into the text field below the pop-up menu instead, this query is used  to indentify promising links.
Example: 
The query 'Devonian Period -County' follows links containing 'Devonian' or 'Period' but not containing 'County'.
In the pop-up menu choose which links you want DEVONagent Pro to follow:
	[image: Icon]Off: Follows no links.
	[image: Icon]All: Follows all promising links.
	[image: Icon]On Same Host: Follows all promising links leading to the same server (domain).
	[image: Icon]In Same Directory: Follows all promising links leading to pages in the same directory.
	[image: Icon]In Subdirectories: Follows all promising links leading to pages in the same directory or its sub-directories.

On the right-hand side of the pop-up menu select how many levels deep you want DEVONagent Pro to follow links. One or two levels generally make sense, more is often overkill.
Use the text field below the slider to provide an additional search query that defines which links DEVONagent Pro follows. Use this option to fine tune your settings if you find that DEVONagent Pro follows meanlingless links due to the construction of the result pages. Generally, you should leave this field blank and let DEVONagent Pro follow all links matching the entered or default query; the automatically chosen term is displayed in this case.
Example: 
Enter '*' to let DEVONagent Pro follow all links, regardless whether or not their text description matches the query.

Express search 
Check Express Search to enable 'express' mode. In 'express' mode DEVONagent Pro returns results fast, but does not filter the results. If unchecked, DEVONagent Pro operates in 'agent' mode, which is slower but returns post-filtered results and is a more precise and powerful tool.
Note:
 Scanners and secondary search terms, the similar pages filter, and following links require 'agent' mode. Some plugins may also require 'agent' mode; others may not support 'express' mode.

Language 
Language: Use this pop-up menu to filter out all pages that do not match the selected language (Dutch, German, English,...) or script system (Arabic, Greek, Hebrew,...) Instead of simply looking for language tags, this filter actually analyzes the page itself.
Ignore Diacritics: Check this option to automatically convert diacritics for analysis into a normalized form. This also finds pages that contain German umlauts, French or Czech accents, or other diacritical characters.
Example: 
Uncheck Ignore Diacritics to search for a word with accented characters when you definitely don't want to find the unaccented variant.
Fuzzy: Check to search 'fuzzy'. This also finds words with similar but not identical spelling, e.g., 'gray' instead of 'grey'.

Filters, scanners,... 
Filters: Check the following filters to automatically filter out special pages you don't want to include in the results list:
	[image: Icon]Similar Pages: Filters out pages similar to results previously found in the search run.
	[image: Icon]Archived Pages: Filters out all pages already stored in the  archive. DEVONagent Pro compares only the URLs in this case, not the actual page content.

Scanner: Scanner plugins post process and filter the list of found pages by formal criteria. Read more about scanners in the appendix.
Example: 
Use this powerful feature unique to DEVONagent Pro to filter, for example, all pages except those containing a thumbnail gallery, linking to Office documents, or containing email addresses.

Comments 
Enter a brief description for a search set here. This description is shown in the tooltips of the magnifier pop-up menu in a search window.


Advanced tab
On the Advanced tab, you define in which parts of webpages DEVONagent Pro searches, which type of files it searches, and whether it accepts all pages or only new results.
[image: Search Set Editor, General Tab]
Search in 
Choose which parts of a document DEVONagent Pro searches for the query. Not all file types have all characteristics.
	[image: Icon]Title
	[image: Icon]Text
	[image: Icon]URL
	[image: Icon]Keywords
	[image: Icon]Description
	[image: Icon]Objects


Files 
Choose which file types DEVONagent Pro searches and accepts as results.
	[image: Icon]HTML & XHTML pages
	[image: Icon]Atom, RSS & JSON feeds
	[image: Icon]Plain text documents
	[image: Icon]PDF & PostScript documents
	[image: Icon]OpenOffice & StarOffice documents
	[image: Icon]Rich text documents
	[image: Icon]Microsoft Word documents


Results 
Choose if you want DEVONagent Pro to accept results only from new pages or from all found pages.
	[image: Icon]All pages: Always accept all matching pages.
	[image: Icon]Only new pages: Accept only new matching pages.

DEVONagent Pro keeps an internal log of found results to recognize which are new. It also lists the number of results stored in the log. To clear the internal log, click the Reset button.

Exclude 
The Exclude Domains and Exclude Links fields allow you to explicitly exclude domains and links from being used or followed when you use this search set. Add the domains or links that you want to be excluded into the text fields. You can use asterisk (*) wildcards to include e.g. all subdomains or partial links.


Sites tab
The Sites tab allows you to define a list of webpages that DEVONagent Pro scans (crawls) or searches when you use this search set. DEVONagent Pro downloads each of these pages and tests whether it matches your query, just like a private search engine of your own. Alternatively it runs a site search on it using common search engines. Use it together with the default query to scan your frequently visited pages for important keywords.
[image: Search Set Editor, Sites Tab]
Managing the Sites List 
To add a page to the list, enter the URL into the location field at the bottom of the window. If the page requires a user name and password, enter them into the appropriate fields. Click the + button to add the page. To remove a page, select it in the list and click the - button.
You can also use drag-and-drop or copy/paste to add URLs to the sites list, and use the context menu to open the page in a browser window or copy the URL. This also adds the title of the page to the Info column when possible. You can copy URLs in this list to the clipboard or drag them to other applications, too.
You can use ranges like [01-31] or [1-31] to quickly add whole ranges of URLs. Add "https://www.classicfm.nl/playlist/per-dag/201202[01-29]" to add all playlist from .../20120201 through .../20120229.
Uncheck a page to exclude it temporarily from being scanned; check the page to include it in the next search run.

Crawl vs. Search mode 
DEVONagent Pro can either crawl (scan) or search sites added to the list. You can set this option individually for each site.
	[image: Icon]Crawl: Downloads the page and adds it to results when it matches the query.
	[image: Icon]Search: Searches the site using common search engines. The found results are downloaded and added to the results when they match the query.

Depending on your settings, promising links are followed.

Taking over URLs 
To take over bookmarks from other applications and create new search sets from them, use drag-and-drop or copy/paste, or import bookmarks or OPML files. Open the settings editor and use File > Import or the Action menu to import bookmarks from Camino, Firefox,  OmniWeb or Safari, as well as OPML files generated by news readers or DEVONthink.

Context menu 
The context menu allows you to work with website addresses selected in the sites list.
	[image: Icon]Open: Opens the selected sites in separate web browser windows.
	[image: Icon]Open In Tabs: Opens the selected sites in separate tabs in a new web browser window.
	[image: Icon]Launch URL: Opens the website in your default web browser.
	[image: Icon]Enable/Disable: Checks or unchecks an item. Unchecked (disabled) websites are not scanned when using this search set.
	[image: Icon]Copy: Copy the URL of the selected website to the clipboard.
	[image: Icon]Paste: Pastes a URL from the clipboard to the list, effectively creating a new item.
	[image: Icon]Delete: Deletes a selected item.



Plugins tab
The Plugins tab defines which plugins (interfaces to search engines) DEVONagent Pro uses when you use this search set in the search window.
[image: Search Set Editor, Plugins Tab]
Plugin List 
Plugins are grouped. Expand or collapse groups by clicking the grey triangle in front of the group name, like in the Finder. Check all plugins that you want DEVONagent Pro to use for this search set; uncheck all others. Check or uncheck a group to check or uncheck plugins contained within the group. Select a plugin to display a short description.
To find out which search engines a plugin uses to get results, use Window > Plugins & Scanners or see the appendix.
Example: 
Check "Images", "Info (Pictures)" and "Picsearch (Images)" to search all major picture search engines.

Results per Plugin 
This value defines the number of results delivered by every plugin. It limits the results pool to the most relevant <n> results. Adjust this to whatever suits your requirements; the default value is 100.


Actions tab
The Actions tab lets you attach additional actions to a search set that DEVONagent Pro executes after finishing a search run using this search set.
[image: Search Set Editor, Actions Tab]
Interface 
	[image: Icon]Bounce Dock icon: Bounces DEVONagent Pro's Dock icon once when the search run is completed.
	[image: Icon]Zoom and bring to front: Zooms the search window and makes it the frontmost window.
	[image: Icon]Use Notifications: Posts a notification on OS X 10.8 "Mountain Lion" or later.
	[image: Icon]Play sound: Plays a sound. Select the sound to be played from the pop-up menu; all systemwide alarm sounds are available.
	[image: Icon]Speak text: Speaks entered text. Use the escape sequence "%d" in the text to announce the number of found items.


Results 
	[image: Icon]Archive results: Adds all found pages to the internal archive.
	[image: Icon]Add results to DEVONthink: Adds all found pages to the currently opened DEVONthink database. Choose the desired format and destination from the popup menus below this option.
	[image: Icon]Send mail to: Sends a summary of the found information to an entered email address. This is especially useful when used with a  schedule.
	[image: Icon]Execute script: Executes an AppleScript. Use this to do whatever you like with the found information, e.g., feed it into a local workflow or post automatically to a website.

Note:
 The email function uses the email account defined in Preferences, Email tab.


Schedule tab
The Schedule tab is what makes DEVONagent Pro a bona fide information agent. It lets you schedule automatic query runs hourly, daily or weekly, and return the results by email, archive them internally, or add them to your DEVONthink database.
[image: Search Set Editor, Schedule Tab]
Note:
 A scheduled search set uses the default query you enter on the "General" tab and runs this query at the scheduled time. Make sure to enter a default query when you use the scheduler.
Frequency, ... 
	[image: Icon]Frequency: Define if you want DEVONagent Pro to run the search set hourly, daily, or weekly, or select Never to switch the scheduler off.
	[image: Icon]Time of Day: Define at which time of the day DEVONagent Pro runs the search set.
	[image: Icon]Day of Week: Define on which day of the week DEVONagent Pro runs the search set.


Options 
	[image: Icon]Quit when done: Quits DEVONagent Pro after the search run is completed.
	[image: Icon]Close window: Closes the search window when the search run is completed.
	[image: Icon]Ignore cache: Ignores the cache and always load all pages from the Internet. Uncheck to use DEVONagent Pro's cache and to reduce network traffic.
	[image: Icon]Next run: Checks when this search set will run next (informative only).



Menus
A complete listing of all commands DEVONagent Pro offers in the menu bar, the global Services menu, and the handy Dock menu.
The DEVONagent Pro menu
The DEVONagent Pro menu is similar to the application menu in any Mac application. It contains commands for displaying the splash screen, opening the preferences window,accessing the Services menu, hiding and showing windows, and, of course, quitting the application.
About DEVONagent Pro, ... 
	[image: Icon]About DEVONagent Pro: Shows information about DEVONagent Pro including the version number and licensing information.
	[image: Icon]Check for Updates: Checks if updates for DEVONagent Pro are available. By default, DEVONagent Pro checks for updates automatically; change your update settings in the Preferences, Update pane.

Note:
 No information from your computer is uploaded to the DEVONtechnologies server during the check for updates. DEVONagent Pro only downloads a file listing the most current versions to your Mac.

Preferences, ... 
	[image: Icon]Preferences: Opens the Preferences.
	[image: Icon]Private Browsing: Select this command to check or uncheck the private browsing mode. If this menu item is checked, DEVONagent Pro clears all caches, history files, and the find pasteboard after quitting, so that anyone using this user account on this computer  cannot later discover your search history. This option also prevents DEVONagent Pro from storing previous search terms in the Recent Searches sub-menu of the magnifying glass pop-up menu of search windows.
	[image: Icon]Empty Cache: Empties the disk cache that is used to speed up browsing. Use this if you are running out of disk space or when you feel that pages or elements are not up-to-date. Emptying the cache effectively forces DEVONagent Pro to download from the Internet all files in their most recent versions.


Purchase, ... 
	[image: Icon]Purchase: Opens the DEVONtechnologies website and places DEVONagent Pro into your shopping cart. If this copy of DEVONagent Pro is already licensed, you will be presented with the choice of buying an upgrade for your existing license or buying another full license.
	[image: Icon]Enter License: Use this command to enter your licence code. Make sure you enter ALL the details EXACTLY as they appear in the licence code email. It is best to use copy-and-paste for transferring name, organization, and licence code from the email message to the appropriate fields. Make sure not to highlight any spaces before or after the required information.

Note:
 Enter License changes into License as soon as you  enter a valid license code.

Services 
	[image: Icon]The Services sub-menu gives you access to special commands published by other Mac applications such as TextEdit or Safari, or by services extensions such as our own WordService or CalcService. Also, DEVONagent Pro publishes its own services. [Read more...]



The File menu
The "File" menu contains all commands that create new windows, open or save files or settings, and print.
New Search, ... 
	[image: Icon]New Search: Opens a new search window. You use search windows to send queries to a predefined search set or a selected plugin, that then queries one or multiple search engines and presents the weighted results. Search windows are what give DEVONagent Pro its name and purpose.
	[image: Icon]New Plugin: Opens the Plugins & Scanners window and lets you create a new custom plugin. Use this function to easily create a plugin for your favorite yet-to-be search engine.


New Browser, ... 
	[image: Icon]New Browser: Opens a new web browser window.Use this function to use DEVONagent Pro as a standard web browser that is optimized for research. The web browser is based on the same WebKit engine used by Safari.
	[image: Icon]New Tab: Creates a new tab in the frontmost web browser window.If the frontmost window is a search window rather than a web browser window, this command opens a new web browser window instead.
	[image: Icon]Open Location: Brings the address field of the frontmost web browser window into focus. If no web browser window is open, DEVONagent Pro opens a new one, equal to File > New Browser.


Open File, ... 
	[image: Icon]Open File: Opens a local file for viewing in a new web browser window or in a previsouly saved search. Alternatively, drag the file onto DEVONagent Pro's icon in the Dock.
	[image: Icon]Open Recent: Lists the recently used saved searches so that you can quickly open them.


Save As, ... 
	[image: Icon]Save, Save As: Saves the content of the frontmost web browser window in its original format or a search run for future reference. Webpages are saved as pure HTML code or webarchives (see below), images, movies, and PDFs in their respective formats. Search runs are saved as '.agentSearch' files that can be double-clicked in the Finder or opened via File & Open. They include the term, the used set or plugin, the settings, the results and their sortings, the digest, the log, and a Quick Look preview.


Import 
	[image: Icon]Sets: Imports saved search setsand adds them to the list of available search sets. You also can import saved search sets by double-clicking them in the Finder or by dragging them to DEVONagent Pro's Dock icon.
	[image: Icon]OPML: Imports all URLs contained in an OPML file and creates a new search setwith the URLs in the Sites tab. Use this to import RSS feeds exported as OPML from a news reader.
	[image: Icon]<Application> Bookmarks: Imports Camino, Firefox, Chrome, OmniWeb, or Safari bookmarks and creates a new search set with all imported URLs in the Sites tab. Both site and news feed bookmarks are supported. If a web browser window is frontmost, the bookmarks will be added to DEVONagent Pro's own bookmark list. 
	[image: Icon]Safari History: Imports the Safari history file and creates a new search setwith all imported URLs in the Sites tab.


Export 
	[image: Icon]Digest: Exports the digest as plain or rich text file. This command can also export the topics map as a PDF document or OPML for outliners and mind-mapping applications.
	[image: Icon]Report: Exports a search report as PDF, CSV (comma-separated values), HTML, or OPML file. Use the CSV or OPML formats to export all results in a structured way in order to re-import them into other applications such as Microsoft Excel or Apple Numbers.
	[image: Icon]Results: Exports selected search results in their original formats, or as bookmarks, plain text files or rich text files.
	[image: Icon]Sets: Exports one or more selected search sets and saves them as files. These files can be re-imported using File > Import > Sets or by double-clicking them in the Finder. Use exported sets to shared them with other DEVONagent Pro users or between computers.


Page Setup, Print 
	[image: Icon]Page Setup: Opens the standard page setup dialog.
	[image: Icon]Print: Prints the contents of the frontmost window.



The Edit menu
The "Edit" menu contains all commands and options related to editing. You'll find the classic Mac cut/copy/paste and find/replace commands here, as well as many more.
Undo, Redo 
	[image: Icon]Undo: Takes your changes back one step. Undo mainly works for text edits, but will not bring back deleted documents.
	[image: Icon]Redo: Redo re-does the last undone edit.


Cut, Copy, Paste 
	[image: Icon]Cut: Cuts the selected items or text passages.
	[image: Icon]Copy: Copies the selected items or text passages to the clipboard.
	[image: Icon]Copy URL: Copies the URL of the selected page or frontmost web browser window to the Clipboard.
	[image: Icon]Paste: Pastes whatever is on the Clipboard.
	[image: Icon]Clear: Deletes the selected item or piece of text.
	[image: Icon]Complete: Auto-completes a word in text and search fields as well as in text views. This OS X standard function relies on the dictionary you have selected in the spellchecker (see below).
	[image: Icon]Select all: Selects all contents of the frontmost window.
	[image: Icon]Deselect all: Deselects all contents of the frontmost window. Hold the ⌥Option key to show this menu item.


Find 
This sub-menu contains commands for finding and replacing text. In most ways it is similar to the Find command in most Mac application, but it also contains DEVONagent Pro-specific items.
	[image: Icon]In Internet: Opens a new search window.
	[image: Icon]In Results: 
	[image: Icon]Find...: Opens the standard find panel.
	[image: Icon]Find Next/Previous: Jumps to the next or previous
				occurrence of the find term.
	[image: Icon]Use Selection for Find: Copies the selected piece of
				text to the find clipboard or into the search field of the find
				panel if it is open.
	[image: Icon]Scroll To Selection: Scrolls the displayed documents to
				the current selection.


Spelling, ... 
	[image: Icon]Spelling and Grammar: The spell and grammar checker. Useful for checking text, e.g., when filling out form fields.
	[image: Icon]Speech: Speaks a selected piece of text.
	[image: Icon]Special Characters...: Shows the standard special characters panel for inserting characters that you cannot enter directly with your keyboard, such as accented or umlauted characters.



The Data menu
The Data menu provides commands for opening search results, exporting them to DEVONthink, archiving them, or organzing them in the built-in archive.
New Group, ... 
	[image: Icon]New Group: Creates a new group in the archive. To create a sub-group, select an archive group first, then use this command.
	[image: Icon]Open: Opens the selected search results in new web browser windows. Same as double-clicking the results.
	[image: Icon]Open In Tabs: Opens the selected search results in separate tabs in a new web browser window.
	[image: Icon]Launch URL: Opens selected search results in your default web browser. If DEVONagent Pro is your default browser, this command is equal to "Data > Open..."


Add to DEVONthink, ... 
	[image: Icon]via Clip to DEVONthink: 
	[image: Icon]Resource: Adds the selected page or document as-is to DEVONthink.
	[image: Icon]Bookmark: Saves links to the selected pages as bookmarks.
	[image: Icon]Rich Text: Saves selected text as a new text document.
	[image: Icon]Summary: Saves the whole digest as text document. Available on the Digest and Results tabs of Search windows as well as in the archive.
	[image: Icon]Formatted Note: Saves the selected page as new formatted note.
	[image: Icon]Markdown: Saves the selected page as new Markdown document.
	[image: Icon]PDF (one page): Saves the selected pages as PDFs without page breaks. A long webpage will be saved as one, very long page, making this function ideal for archiving. Only available in the web browser.
	[image: Icon]PDF (paginated): Saves the selected pages as PDFs with page breaks. Use this for archiving webpages that you may want to print later.
	[image: Icon]Web Archive: Saves webpages as webarchives. Webarchives are self-contained files that include one webpage that includes all additional files necessary for displaying, e.g., embedded images or movies. Only available in the web browser.

DEVONagent Pro adds 'DEVONagent Pro plus the name of the plugin used to find the page and its version to the comments when adding to DEVONthink.
Note:
 These items are only available when DEVONthink is installed on your Mac.

Add To Set, ... 
	[image: Icon]Add To Set: Adds selected pages, e.g., search results, to the "Sites" listof a search setyou select from the sub-menu. These pages will be scanned for an entered query the next time you use this search set and can be useful to include in future searches. Select "New Set..." from the sub-menu to create a new search with the selected pages.
	[image: Icon]Add To Archive: Adds the selected results to the archive,creating a new group for current search run. If a group for this search run already exists, any subsequently added page from same search run will be added to this archive group. 
	[image: Icon]Add All To Archive: Appears insteat of Add To Archive when you hold the ⌥Option key down. Adds all results of a search run to the archive,creating a new group for them. Use this command to archive all results of a search run with one click.


Mark All Read, ... 
	[image: Icon]Mark All Read: Marks the selected results as read or unread.
	[image: Icon]Delete: Deletes search results from a results list in a search window,as well as groups or items from the  archive.
	[image: Icon]Delete Domain: Deletes all results from the selected domains from the current results list.
	[image: Icon]Delete & Exclude Domain: Deletes the selected search results from a results list in a search window and adds the domains of the pages to the list of excluded domains. All other search results matching the exluded domains are removed. Use this function to quickly exclude an unwanted domain without having to block it via the Preferences. Alternative menu item to Delete Domains.
	[image: Icon]Clear Log: Clears the Log tab of the frontmost Search window.

Note:
 Use Delete and Delete & Exclude Domain with care. You cannot undo these commands.


The Sort menu
The Sort menu sorts search results in a variety of ways.
Unsorted, By Name, ...:
	[image: Icon]Unsorted: List results in their natural order. Useful after opening a saved search to easily view new results.
	[image: Icon]Name: List results sorted by name.
	[image: Icon]Date: List results sorted by date.
	[image: Icon]Size: List results sorted by size.
	[image: Icon]URL: List results sorted by URLs.
	[image: Icon]Top Level Domain: List results sorted by their top level domain.
	[image: Icon]Relevance: List results sorted by relevance.
	[image: Icon]Number of Objects: List results sorted by the number of found objects.

Top Level Domain means the last part of a website address. Usually it is defined by the country the website is located in, e.g., '.de' for Germany or '.cz' for the Czech Republic, or by function, such as '.com' for a world-wide commercial site or '.mil' for a US military site.
Relevance is the relevance of a result compared to all collected results in respect to the query. This is the default sorting order.
Ascending, Descending:
	[image: Icon]Ascending: Sorts items ascending.
	[image: Icon]Descending: Sorts items descending.


The View menu
The View menu allows you to switch between the various tabs of a Search window, to switch Cover Flow on and off, and to customize how objects are presented in web browser windows.
Digest, ... 
	[image: Icon]Digest: Switches to the "Digest" tab. The digest shows a summary of the found information (not the pages), sorted by relevance. In addition, it visualizes topics in a topics map that lets you navigate the results graphically. Use the digest and the topics map to work with the information itself instead of manually visiting webpages.
	[image: Icon]Results: Switches to the "Pages" tab. The "Pages" tab lists all found pages, sorted by relevance (or any sorting order you choose in the "Sort"menu). A preview pane displays the relevant text parts of a selected result.
	[image: Icon]Log: Switches to the "Log" tab. The log lists all webpages that DEVONagent Pro has filtered out as being irrelevant to the query or outdated. View a selected page in the preview page. Use the log to see how many pages you DON'T have to look at because you're using DEVONagent Pro instead of another search engine.
	[image: Icon]Settings: 
	[image: Icon]Advanced: 


Summary, Objects 
	[image: Icon]Summary: Selects the Summary tab of the Pages tab of Search windows.
	[image: Icon]Objects: Selects the Objects tab of the Pages tab of Search windows.


Cover Flow, ... 
	[image: Icon]Cover Flow: Switches between the regular display of results or tabs and Cover Flow. Cover Flow lets you browse graphically and quickly through results or the pages opened in multiple browser tabs.
	[image: Icon]Quick Look: Shows a Quick Look preview for the selected search result.
	[image: Icon]Slideshow: Shows a slideshow for multiple selected search results. Hold the Shift key to show this alternative command.
	[image: Icon]Inverse Appearance: Inverts the colors of the results list in search and browser windows to match it with Cover Flow. Uncheck to return to the regular black-on-white appearance.
	[image: Icon]Show Icon Preview: Shows or hides the icon previews in Results  tab of search windows, Sidebar drawer and See Also tab the Inspectors pane of web browser windows and the archive. 
	[image: Icon]Use Small Icons: When checked, objects are shown with small icons and more information in the sidebar of web browser windows. When unchecked, objects are shown with large icons and no details.


Show Toolbar, ... 
	[image: Icon]Hide/Show Toolbar: Hides or shows the toolbar of the frontmost window.
	[image: Icon]Customize Toolbar: Lets you configure the toolbar of the frontmost window.
	[image: Icon]Enter/Exit Full Screen: Puts the frontmost window into full screen or back into windowed mode. Press ⎋ to return to windowed mode.



The Web menu
The Web menu contains all commands that are directly related to web browsing, from quickly turning Java on or off to switching between views and reloading a webpage. All commands in this menu act on the frontmost web browser window.
Enable Plugins, ... 
	[image: Icon]Plugins: Enables or disables plugins.
	[image: Icon]Java: Enables or disables Java.
	[image: Icon]JavaScript: Enables or disables JavaScript.

Use these options to quickly switch plugins, Java, or JavaScript on and off without visiting the Preferences.

Stop Loading, ... 
	[image: Icon]Stop Loading: Stops loading a the webpage. This is equal to clicking the reload/stop button on the address bar of a web browser window when a page is loading.
	[image: Icon]Reload Page: Reloads the webpage. This is equal to clicking the reload/stop button on the address bar of a web browser window when a page is completely loaded.
	[image: Icon]Actual Size: Zooms the page to its actual size.
	[image: Icon]Zoom In: Zooms in.
	[image: Icon]Zoom Out: Zooms out.
	[image: Icon]Zoom Text Only: When this option is checked, only the text of the page is made larger and smaller. When unchecked, DEVONagent Pro uses Safari-4-style zooming.
	[image: Icon]Text Encoding: Changes the text encoding used for displaying a webpage. Use this sub-menu to manually adjust the text encoding if DEVONagent Pro displays accented characters, umlauts or East Asian characters incorrectly. Generally, websites publish their encoding and DEVONagent Pro reads this metadata for adjusting the encoding automatically.


View, ... 
	[image: Icon]Source Code: Shows the source code of the webpage.
	[image: Icon]Text: Shows only the pure text of the webpage.
	[image: Icon]Layout: Shows the webpage rendered (normal).

These three options switch the mode of the frontmost web browser window between different modes. Use these modes to view only the raw text of a layout-intensive webpage, or to switch to the source code to find information that is hidden in the code but not visible in the layout. DEVONagent Pro displays the source code with syntax coloring. The text only mode is also useful for copying/extracting information from pages with a complex table layout.

Sidebar 
	[image: Icon]Show: Shows or hides the sidebar.
	[image: Icon]Bookmarks: Switches to the bookmarks pane of the sidebar.
	[image: Icon]Results: Switches to the results pane of the sidebar.


Inspectors 
	[image: Icon]Show: Shows or hides the Inspectors tab of the frontmost web browser window.
	[image: Icon]Properties: Switches to the properties tab.
	[image: Icon]Objects: Switches to the objects tab.
	[image: Icon]See Also: Switches to the See also tab.


Address Bar 
	[image: Icon]Address Bar: Shows or hides the address bar. Hiding the address bar gives you more useable screen space for the displayed webpage.



The History menu
As with any web browser, the History menu lists all webpages previously visited, divided into subfolders for each day, and marked with the date and time you last viewed them.
Back, Forward, Clear History 
	[image: Icon]Back, Forward: Moves back and forth between the visited pages. These commands are equal to the back and forward buttons in the address bar of web browser windows. Since there is no history when private browsing is active, these commands are not available when private browsing is switched on.
	[image: Icon]Clear History: Clears the history.


Visited webpages 
The rest of the History menu lists the previously visited webpages, sorted from the top by age.


The Go menu
The Go menu contains commands for navigating back and forth through a results list in a search window or occurrences of a search word, as well as for using and managing bookmarks.
Next/Previous Result/Occurrence 
	[image: Icon]Next/Previous Result: Navigates back and forth through the results lists to which the displayed webpage belongs. Use these commands to go through the pages resulting from a search run.
	[image: Icon]Next/Previous Occurrence: Jumps to the next or previous occurrence of the search term, e.g., in the digest or pages tabs of search windows.


Bookmarks 
Besides the commands mentioned above, the Go menu gives you access to the bookmarks of Safari, Camino, Firefox, or OmniWeb, or DEVONagent Pro's own bookmarks list. Select which bookmarks DEVONagent Pro shows in the Go menu in the preferences.
	[image: Icon]Add: Adds a bookmark for the currently shown webpage.
	[image: Icon]Add Folder: Adds an empty folder to the bookmarks list.
	[image: Icon]Edit: Opens an edit sheet for the currently selected bookmark. This function is unavailable when two or more bookmarks are selected.
	[image: Icon]Delete: Deletes the selected bookmarks.
	[image: Icon]<Bookmarks>: Opens any selected bookmark; use Open in Tabs in any bookmark folder to open all bookmarks in the folder in separate tabs.

For these commands to work, a web browser window needs to be active and DEVONagent Pro use its own bookmarks. You cannot yet edit Safari's bookmarks from within DEVONagent Pro.

Bonjour 
The Bonjour part of the Go menu lists web services advertised on the local network via Bonjour, e.g., printers with web interfaces or shared DEVONthink Pro Office databases.

Workspaces 
Workspaces save the content and positions of all open windows so that you can restore them later. This is ideal if you are working with the same set of windows over and over again. Save the windows as a workspace and recall them whenever needed.
	[image: Icon]Add: Saves the currently open windows as a workspace.
	[image: Icon]Edit: Opens a window that allows you to edit saved workspaces. Click on a workspace name to change it, reorder it by dragging, and delete it with the . button.
	[image: Icon]Update: Updates the last used workspace to the currently open windows.
	[image: Icon]Workspaces: Restores to a previously saved workspace.



The Window menu
As with any Mac application, the Window menu lists all open windows of DEVONagent Pro and gives you access to commands for managing them.
Window Commands:
	[image: Icon]Close/Zoom/Minimize: These three commands resemble the red, yellow and green buttons of any window title bar and consequently close the window, maximize it or create an icon on the dock. No magic here.
	[image: Icon]Bring All to Front: Brings all windows of DEVONagent Pro to the front.
	[image: Icon]<Window name>: Brings a selected window to the front.

Tab Commands:
	[image: Icon]Close Tab: Closes the current tab of the frontmost web browser window.
	[image: Icon]Select Next/Previous Tab: Switches to the next or previous tab of the frontmost web browser window.

Archive ... Downloads:
	[image: Icon]Archive: Opens the Archive window.
	[image: Icon]Search Sets: Opens the Search Sets panel, which allows you to edit the available search sets.
	[image: Icon]Plugins & Scanners: Opens the Plugins & Scanners panel that lists all installed plugins and scanner modules. Use this panel to see which plugins or scanner modules are available, get more information about them, and activate and deactivate them.
	[image: Icon]Downloads: This command opens the Downloads panel. Use it to download files from the Internet to your computer.


The Services menu
The Application > Services menu (where 'Application' is the name of the frontmost application) allows access to special commands published by other applications, such as TextEdit or Safari, or by services extensions such as DEVONtechnologies' WordService or CalcService. Also, DEVONagent Pro publishes its own services in the Services menu.
[image: The Services menu]
The Services menu is a sub-menu of every application's application menu, the menu named after the application itself and carrying the About X, Hide ... and Quit commands. Services usually act on a selection, e.g., selected text or files.
Services provided by DEVONagent Pro:
	[image: Icon]Lookup: Opens a new search window in DEVONagent Pro with the query field pre-filled with the selected text. Use this command to quickly search for a selected piece of text.
	[image: Icon]Open URL: Opens a selected piece of text as a URL in DEVONagent Pro. Use this to quickly select a URL, e.g., in an email message, and open it in a DEVONagent Pro web browser window.

Use Application > Services > Services Preferences to change keyboard shortcuts or hide selected commands to clean up the Services menu.
Note:
 After installing DEVONagent Pro you may need to log out and back in again for the Finder to recognize the new Services menu commands and shortcuts. If one or more DEVONagent Pro Services menu commands does not have a keyboard shortcut assigned to them, perhaps another application grabbed it. OS X automatically assigns the correct shortcut when no other application asks for the same key combination.

The Scripts menu
The Scripts menu is located left of the Help menu and shows a graphic AppleScript 'S' symbol instead of a normal menu title. It contains a collection of useful predefined AppleScripts you can use directly from within DEVONagent Pro.
Some of the scripts work without a selected document; others require you to select the document you want the script to interact with. In general, the script will tell you what you have to do when you select it from the Scripts menu.
[Read more...]

The Help menu
The Help menu contains commands for opening the integrated help pages or the support assistant, or for visiting the DEVONtechnologies website.
DEVONagent Pro Help 
These commands open the integrated help pages that are equal to the document you reading or open the release notes.

Support Assistant, Tutorials 
Your Account: Opens your customer account page where you can look up your details and licenses.
Support Assistant: Opens the support assistant where you can, for example, read the FAQ, visit the user forum, download this documentation as printable or screen-readable PDFs, retrieve your license code, or log in to your customer account.
Tutorials: Opens the assistant on the Tips & Tutorials page.
Click here [special link, not enabled in ebook] to open the support assistant.
Note:
 If you purchased DEVONagent Pro from the Mac App Store, not all options dealing with licenses or upgrades are available.

DEVONtechnologies 
Visit the DEVONtechnologies website and ask questions or meet your fellow users in the lively user forum. Read the list of frequently answered questions we have compiled for you, or contact DEVONtechnologies and provide feedback directly to the development team.
You can also send a bug report including the most recent crash logs. This is an alternative menu item to Contact us.


The Dock menu
The Dock menu appears when you ⌃-click or right-click DEVONagent Pro's icon in the Dock. In addition, DEVONagent Pro's icon shows a badge with the number of found results.
[image: The Dock menu]
For all Mac applications, the Dock menu provides a selection of the commands of the application menu.
	[image: Icon]<Window Name>: Brings any open window of DEVONagent Pro to the front.
	[image: Icon]Options > ...: Keeps DEVONagent Pro in the Dock or removes it, adds DEVONagent Pro to your login items, or reveals the DEVONagent Pro application package in the Finder.
	[image: Icon]Hide: Hides all windows of DEVONagent Pro.
	[image: Icon]Quit: Quits DEVONagent Pro.

Besides these standard commands, DEVONagent Pro adds a number of its own commands to the Dock menu to make them easily accessible whenever the application is running.
	[image: Icon]New Search...: Opens a new DEVONagent Pro search window. Same as File > New Search
	[image: Icon]New Browser...: Opens a new DEVONagent Pro web browser window. Same as File > New Browser"
	[image: Icon]Bookmarks, Bonjour, Workspaces: Gives you access to your bookmarks, depending on your settings in Preferences > Bookmarks, Bonjour services, and workspaces. Equals the Bookmarks, Bonjour, and Workspaces parts of the Go menu.


Windows and panels
DEVONagent Pro uses a number of different windows for running search queries, displaying webpages, setting up search sets, and downloading files.
Search window
[image: The Search Window and its Elements]
The search window is where you start search runs and work with the results. You open a new search window with File > New Search In its minimized form, the search window consists only of an entry field for the query, a pop-up menu for selecting the search sets to be used, a Start/Stop button, and an Append button. In maximized form, it is divided into four tabs: Digest, Results, Log, and Settings. You can switch between minimized and maximized form by clicking the green window gadget. Also, you can choose whether you want to open new search windows as either minimized or maximized in the preferences, "General" tab.
To start a search run, select the correct search set from the magnifier pop-up menu in the entry field, enter your query and click the Start button. DEVONagent Pro then queries all search engines and scans all webpages defined by the search set. As soon as the search run has finished (or you have clicked the Stop button), DEVONagent Pro expands the search window, if necessary, and presents the results in either the Digest or the Results tab, depending on your preferences.
If you have already performed a search run, you can also use the Append button instead of Start to append the search results to the previously collected ones instead of replacing them.
Note:
 DEVONagent Pro limits search runs to 500.000 result pages and 32 GB of data. This prevents flooding your hard disk when your search query or your Follow Links settings are too broad.
Magnifying glass pop-up menu 
The magnifying glass pop-up menu [image: ] lets you select the search set you want to use for your search. For a general search, use the search set Web (Fast). You can define your own search sets in the Search Sets window, which you can open by selecting Edit Search Sets from the magnifier pop-up menu.
User-defined plugins are listed in bold.
Note:
 You can easily create a new search set by using the + button left of the search term field. Use this to run the same query with exactly the same settings again in the future.
Plugins: In addition, this pop-up menu gives you direct access to every installed plugin. This way, you don't have to define a search set just for querying a special search engine once. You can simply pick the one you want to use, enter the query and hit the Start button. Tool tips give you more information about each plugin.
Recent searches: The magnifying glass pop-up remembers the last 25 search terms (when private browsing is not enabled). You recall the terms simply by selecting them from the Recent Searches part of the menu. Remember to select the correct search set or plugin. Clearing the recent serarches empties the system-wide find pasteboard too.
Recently used: Finally, find here the most recently used plugins or search sets for quick access.

Status bar 
The status bar below the search field shows information about the number and size of the downloaded files, found results and objects, as well as unread results.

Digest tab 
DEVONagent Pro's search window is divided into three views, each presenting different aspects of the information that has been collected in a search run. You switch between the views by clicking the tabs separating the search field from the rest of the window.
The digest differs from what traditional search engines and applications display. This is what makes DEVONagent Pro unique. Instead of simply listing the URLs of found pages, the digest shows a list of topic words and two- and three-word expressions that DEVONagent Pro has extracted from the collected data. This list not only includes the entered search words, but also many other words that the artifical intelligence core of DEVONagent Pro found to be important and related to the query. You can sort this list by topic or relevance by clicking the column headers. The number of sentences with occurences is shown for each topic word.
[image: The topics map]
Topics map: In the right-hand side pane, DEVONagent Pro shows short paragraphs from every found webpage until you select one or more topic words. DEVONagent Pro shows an AI-generated visual representation of the selected topic and its relations to other topics in a mind-map style. Two-and three-word word expressions do not show a topics map; for multiple selected topic words DEVONagent Pro always picks the top one.
The selected topic becomes a big blob in the center of the map with related topics arranged around it. The larger a blob, and the more orange or red it is, the more important it is. Topics that are related to the selected word but are not part of the topics list on the left, are shown in blue. Light grey lines indicate closer relationships between topics. Move the mouse over the topic blobs to highlight the connetions to other topics in the graph; click a blob to select it. Double-click a topic in the map to make it the center of the graph. DEVONagent Pro will recalculate the map accordingly. This is similar to selecting another topic word from the list on the left.
Use the arrow buttons in the bottom bar of the topics map area to navigate back and forth through the results in the digest.
Summary: Finally, below the topics map, DEVONagent Pro shows a summary of the extracted information, sorted by relevance. At the end of each extract, you'll find a link to the original source where DEVONagent Pro extracted the data from (click the link with ⌘ held to open it on a new tab instead of in a new window). The summary delivers the actual answer to your query, effectively eliminating the need to go through a long list of links or visit hundreds of webpages manually.
The summary dynamically changes with whatever topic word or words you select in either the left-hand side pane or the topics map. This way, you can use the topics map to navigate through the found information and refocus the summary to whatever you are interested in. You can also click words in the summary with ⌥ held to refocus the topics map on the clicked word.
Note:
 You can also select multiple topics with the ⇧ and ⌘ keys, or enter your own keywords separated by spaces, into the text field below the topics list. For the topics map, DEVONagent Pro will only use the first selected topic word. It does not work with words you enter into the keyword text field.

Results Tab 
List or Cover Flow: The Pages tab is similar to what most search engines deliver: a list of all found URLs including the name of the webpage and a two lines excerpt from where the search terms are found on the page. Sort the list by all the criteria that you can find in the Sort menu. You can also drag results to DEVONthink to quickly archive them in your database.
[image: The Pages tab]
You can browse the results also with Cover Flow. Double-click a page in Cover Flow to open it in a new web browser window; hold the ⌘ key to open the new window in the background.
All pages that you haven't checked yet show a dot in front of them, similar to unread messages in Apple Mail. You can also select results and drag them to other applications, such as an open TextEdit window, DEVONthink, or the Finder, or delete pages from the list that you have found to be unrelated to your research. A badge shows the number of found scanner objects.
Preview area: In the lower pane of the Pages tab, DEVONagent Pro displays either a text preview of the relevant text passages for pages selected in the list above, or all objects found by the automatically applied scanners. Switch between the text preview and the objects returned by the scanners using the navigation bar above the preview.
In addition, you switch between small and large icons, download all or selected objects, and access the action menu from the navigation bar.

Log tab 
The Log tab lists all pages that DEVONagent Pro has skipped.
DEVONagent Pro skipped them because they:
	[image: Icon]Did not match the query
	[image: Icon]Delivers an error message, e.g., the famous error 404 (file not found)
	[image: Icon]Are an advertisement
	[image: Icon]Are index spam created for fooling search engines

You can find a complete list of all codes used in the log in the appendix.
Effectively, the log lists all pages you did not have to look at yourself because DEVONagent Pro did that job for you.
[image: The Log tab]
You can sort the list by date, address, or error message by clicking the respective column headers. Click them again to reverse the sorting order. Use copy-and-paste or drag-and-drop to move or copy URLs to the Downloads panel, to a search set, to DEVONthink, or other applications, e.g., Safari.

Settings tab 
The Settings tab contains some of the options from the General and Advanced of search sets and TEMPORARILY overrides these settings.
[image: Settings Tab]
The Settings tabs offers the following options:
	[image: Icon]Follow Links 
	[image: Icon]Language 
	[image: Icon]Filter & Scanner 
	[image: Icon]Secondary Query 

	[image: Icon]Search In
	[image: Icon]Files

Use the Settings tab to temporarily enable or disable options, e.g., to switch on a scanner without permanently messing up the search set.

Toolbar 
The toolbar of DEVONagent Pro's main windows carries many commands for manipulating the way it displays information and for manipulating selected items. Many of these are simply shortcuts for menu bar commands. Here's a short list of the available tools:
	[image: Icon]Open: Opens the selected page(s) in a separate web browser window.
	[image: Icon]Launch URL: Opens the selected page(s) in your default web browser.
	[image: Icon]Export: Exports the selected page(s) as pure text, RTF(D) or HTML.
	[image: Icon]DEVONthink: Adds the selected page(s) to the currently open DEVONthink database in the format you choose from the pop-up menu. Only available if DEVONthink is installed on your Mac.
	[image: Icon]Add: Adds the selected page(s) to the internal archive.
	[image: Icon]Add All: Adds all found pages to the internal archive.
	[image: Icon]Archive: Opens a window for the internal archive.
	[image: Icon]Delete: Deletes the selected page(s) from the results list.
	[image: Icon]Print: Prints the results list.
	[image: Icon]Search: Searches the results on the Results tab. Use the magnifying glass pop-up menu to adjust your search options.
	[image: Icon]View: Enables or disables Cover Flow and shows or hides icon previews.

Note:
 Not all of these commands are always available. You can customize the toolbar by selecting Viiew > Customize Toolbar or by Control- or right-clicking the toolbar background and selecting Customize Toolbar from the context menu.

Shortcuts & modifier keys 
Like any Mac application, DEVONagent Pro uses modifier keys or shortcuts to access frequently used functions or modify a standard behavior.
	[image: Icon]Command-click: Adds an item to the current selection of items.
	[image: Icon]Shift-click: Selects a range of items.
	[image: Icon]Space, Shift-Space: Scrolls down or up in non-editable text views, e.g., the summary.


Context menu 
The context menu, which appears when you click something with the right mouse button or when you click while holding the ⌃ Control key down, offers a range of commands tailored to what you can do with the clicked object.
Most of the commands offered by the context menu have counterparts in a main menu, so you'll recognize them immediately. However, to save menu bar real estate, DEVONagent Pro gives you access to some options only via the context menu.
	[image: Icon]Open: Opens the selected pages in separate web browser windows.
	[image: Icon]Open In Tabs: Opens the selected pages in separate tabs in a new web browser window.
	[image: Icon]Copy URL: Copies the selected URL to the clipboard.
	[image: Icon]Launch URL: Opens the selected page(s) in your default web browser.
	[image: Icon]Reveal in Finder: Reveals an externally archived page in the Finder.
	[image: Icon]Add to DEVONthink: Adds the pages to your currently open DEVONthinkdatabase in a variety of formats. Same as Data > Add to DEVONthink. Only available if DEVONthink is installed on your Mac.
	[image: Icon]Add to Set > ...: Adds the addresses of the selected page(s) to the sites list of a search set.Select "New Set..." to create a new search set with the selected page(s).
	[image: Icon]Add to Archive: Adds the selected page(s) to the internal archive.
	[image: Icon]Add All to Archive: Adds all pages in the results list to the internal archive.
	[image: Icon]Export: Exports the selected page(s).
	[image: Icon]Mark As Read: Marks the selected pages as read or unread.
	[image: Icon]Delete: Deletes the selected page(s) from the results list.
	[image: Icon]Delete Domain: Deletes all pages from the selected domains from the results list.
	[image: Icon]Delete & Exclude Domain: Deletes the selected search page(s) from the results list and adds the domain(s) of the page(s) to the list of excluded domains. Use this to quickly exclude an unwanted domain, without having to block it via the preferences.
	[image: Icon]Sort by > ...: Sorts the results list by the criteria listed in the sub-menu. Alternative menu item to Delete Domains.
	[image: Icon]Clear Log: Clears the log for the search run. Same as Data > Clear Log.
	[image: Icon]Sort By: Sorts the results list by the selected sort key. [Read more...]

In text areas, e.g., the text preview on the "Pages" tab, DEVONagent Pro also offers the standard context menu commands for text views:
	[image: Icon]Search with Spotlight: Searches for the selected text using Spotlight.
	[image: Icon]Search in Google: Opens your default browser and searches for the selected text in Google.
	[image: Icon]Look Up in Dictionary: Looks up the selected piece of text in the system dictionary.
	[image: Icon]Cut/Copy/Paste: Same as  "Edit > Cut/Copy/Paste".
	[image: Icon]Spelling > ...: OS X's integrated spell checker. Choose "Spelling..." to open the spellchecker panel, and "Check Spelling" to run the spell checker on the text. "Check Spelling as You Type" is not available in read-only text views.
	[image: Icon]Speech > ...: "Start Speaking" speaks selected text, "Stop Speaking" stops speaking, which is useful when speaking a very long piece of text.



Web browser
[image: The browser window and its elements]
Besides being a research tool, DEVONagent Pro is a full-fledged web browser, based on the Safari engine (a.k.a. 'WebKit'). Open a new web browser window by choosing File > New Browser, clicking a link, or by choosing File > Open Location when no web browser window is frontmost.
To visit a website, enter its address into the address field of the toolbar and press ↩ or Enter. Alternatively, drag a URL to DEVONagent Pro's application icon in the Finder or in the Dock, or into an open browser window.
Instead of a URL, you can use keywords to directly send a simple query to a search engine. This effectively replaces the  search field found in Safari and other browsers. The keywords are defined by the plugins, but can be edited individually. If the plugin supports it, keywords use a search engine specific to the system language. Another option is to use DuckDuckgo Bangs in the address field.
Example: 
Enter 'ddg devonthink' to query DuckDuckGo for 'devonthink'; enter '!amz thunderbolt 5' to shop for Thunderbolt 5 products on Amazon.
Tab bar 
The tab bar below the toolbar lists all tabs of the web browser window. Each tab contains a different webpage. Use tabs to open multiple webpages without cluttering your screen with dozens of separate windows. Switch between tabs by simply clicking the tab you want to bring to the foreground. If all tabs do not fit into the available space, DEVONagent Pro shows an optional pop-up menu at the right-hand side of the tab bar listing all available tabs.
Point to a tab for one second without clicking to show a tooltip with a thumbnail preview of the webpage displayed on the tab. This is useful when you cannot remember which page you opened on which tab. Right- or ⌃Control-click a tab to show a context menu.
Inactive tabs show a close button instead of the webpage icon. Also, after the last tab, DEVONagent Pro shows a "+" button for creating new, empty tabs.

Toolbar 
The toolbar of a web browser window can be customized like any other toolbar using View > Customize Toolbar. The following tools are available:
	[image: Icon]Window: Shows or hides the sidebar; switches Cover Flow mode on and off; switches to full screen mode; hides or shows the Inspectors pane.
	[image: Icon]View: Switches between source code, text, and layout views. Use the source code view to inspect how a page is constructed and the text mode to see the raw text without any distractions.
	[image: Icon]Action Menu: Access frequently used commands directly from the toolbar. [Read more...]
	[image: Icon]Back/Forward: Navigates back and forth through the visited pages, like a standard web browser. Similar to "History > Back/Forward".
	[image: Icon]Smaller/Bigger: Makes the text smaller or bigger.
	[image: Icon]Reload/Stop: Reloads the current page (circle arrow icon) or stops loading a page ('X' icon).
	[image: Icon]Address: Type in the URL to load here, or type in a keyword and a simple query. Read more about keywords here. Select the whole address in the address field and drag it to other windows or applications, e.g., the Finder.
	[image: Icon]See Also: Opens a drawer with pages similar to the current one, sorted by relevance. Select a page in the drawer to display it. The originating page is always listed on the top of the list. Use See Also for finding related pages in the results pool. [Read more...]
	[image: Icon]Share: Shares the page via services like iMessage, Mail, Facebook, and AirDrop, or adds it to Safari's Reading List.

If a bookmark for the current page exists in the open DEVONthink Pro databases, a small DEVONthink icon is shown on the right-hand side of the address field.

Inspectors 
The Inspectors pane presents additional information about the displayed web page, e.g. metadata or extracted objects. Depending on the displayed page, none, one, or multiple of the following tabs, can be available:
	[image: Icon][image: ] Properties
	[image: Icon][image: ] See Also

	[image: Icon][image: ] AppleScript scripts
	[image: Icon][image: ] Audio
	[image: Icon][image: ] Code
	[image: Icon][image: ] Downloadable archives
	[image: Icon][image: ] Electronic business cards (.vcard)
	[image: Icon][image: ] Email addresses
	[image: Icon][image: ] Twitter posts
	[image: Icon][image: ] Images
	[image: Icon][image: ] LaTeX files
	[image: Icon][image: ] Links
	[image: Icon][image: ] News feed (Atom, RSS, JSON)
	[image: Icon][image: ] Office documents
	[image: Icon][image: ] Spreadsheet documents
	[image: Icon][image: ] Thumbnail galleries
	[image: Icon][image: ] Cooking recipes
	[image: Icon][image: ] Video (live)
	[image: Icon][image: ] Videos
	[image: Icon][image: ] Wallpapers, desktop pictures
	[image: Icon][image: ] Webcams

Properties tab: The Properties tab shows metadata about the displayed web page.
See Also tab: The See Also tab lists other pages related to the displayed page from three sources:
	[image: Icon]Search: The results of the search run to which the page belongs.
	[image: Icon]Archive: Pages in the internal archive.
	[image: Icon]DEVONthink Pro: The currently open DEVONthink databases.
	[image: Icon]Web: Related pages from the Web, either provided by plugins or common search engines.

Click any item in the pane to display it; double-clicking opens it in a new tab or window. The original page stays at the top of the list so that you can easily go back to it. Results from DEVONthink that have a URL associated with them are also shown with a single click; results without URLs open in DEVONthink on a double-click.
Objects: Which, if any, of the other above tabs are available depends on the web page shown in the window. DEVONagent Pro collects all objects from the page using the available scanners and lists them in separate tabs in the sidebar. Click any found object to display it (double-click to open it in a new tab, if tabbed browsing is enabled, or a new browser window). Click with ⌘ pressed to open the result in a new tab. The Back button brings you back to the original page.
Botttom bar: The bar at the bottom of the sidebar gives you access to commonly used commands, depending on which tab is active.
	[image: Icon]List: Shows objects in a list with small icons. [Read more...]
	[image: Icon]Icons: Shows objects as large icons. [Read more...]
	[image: Icon]Download: Adds the selected objects to the Download Manager. If no item is selected all items will be added.
	[image: Icon]Action: Gives access to the same options as the context menu (see below).

Context menu: The context menu gives you direct access to commands acting on the selected items. Commands are only available when applicable.
	[image: Icon]Open in New Window: Opens the selected items in a new web browser window.
	[image: Icon]Open in New Tab: Opens the selected items in a new tab.
	[image: Icon]Open in PhotoStickies: Opens a selected items in PhotoStickies.
	[image: Icon]Open in DEVONthink: Opens a document located in DEVONthink.
	[image: Icon]Reveal in DEVONthink: Reveals a document located in DEVONthink.
	[image: Icon]Add Link to DEVONthink: Adds a link to the result to DEVONthink.
	[image: Icon]Copy: Copies the selected items to the clipboard.
	[image: Icon]Download: Downloads the selected items (or the items referred to by links).
	[image: Icon]Select/Deselect All: Selects or deselects all items in the list.
	[image: Icon]Use Small Icons: When checked (default), DEVONagent Pro displays small icons in the drawer, including the name and the link to or of the item; when unchecked, it displays large icons, 160 pixels wide, and shows no links.
	[image: Icon]Open Video in Tab: Opens an HTML 5 video in a new tab.
	[image: Icon]Open Video in New Window: Opens an HTML 5 video in a new window
	[image: Icon]Download Video: Downloads an HTML 5 video.


Sidebar 
The sidebar is the place in a web browser window where all additional information is presented, from bookmarks to the list of search results (if the page is part of the results of a current search run) to extracted objects. The sidebar is divided into several sub-tabs:
	[image: Icon][image: ] Bookmarks
	[image: Icon][image: ] Results

Bookmarks: Use the Preferences to choose what bookmarks and additional elements, e.g., Web servers announced via Bonjour, DEVONthink Pro bookmarks, or workspaces, are listed on the Bookmarks pane. If you are using DEVONagent Pro for your bookmark management, use cut/copy/paste, drag-and-drop, or the context menu (see below) to edit your bookmarks.
Results: The Results pane lists all results of the search run that the shown webpage belongs to. This pane is unavailable if the page does not belong to a currently open search run.
Bottom bar: The bar at the bottom of the sidebar gives you access to commonly used commands, depending on which tab is active.
	[image: Icon]+: Adds the current page to the bookmarks.
	[image: Icon]-: Removes the current page from the bookmarks.
	[image: Icon]Back: Selects the previous search results from the current results set.
	[image: Icon]Forward: Selects the next search results from the current results set.
	[image: Icon]Delete: Deletes the current page from the current results set.
	[image: Icon]Action: Gives access to the same options as the context menu (see below).

Context menu: The context menu gives you direct access to commands acting on the selected items. Commands are only available when applicable.
	[image: Icon]Next/previous result: Navigates back and forth through the list of results. Same as Go > Next/Previous Result.
	[image: Icon]Mark as Read/Unread: Marks the selected results as read/unread.
	[image: Icon]Delete: Deletes the result from the results of the search run it was opened from.
	[image: Icon]Delete & Exclude Domain: Deletes the result from the results of the search run it was opened from and adds it to the exclude list in the Preferences.
	[image: Icon]Sort: Changes the sorting of the result list.
	[image: Icon]Cut: Copies the selected items to the clipboard and removes it from the list.
	[image: Icon]Copy: Copies the selected items to the clipboard.
	[image: Icon]Paste: Pastes bookmarks on the clipboard.
	[image: Icon]Add Bookmark: Adds the current page to the bookmarks.
	[image: Icon]Add Bookmark Folder: Adds a new folder to the bookmarks.
	[image: Icon]Import: Imports bookmarks. [Read more...]
	[image: Icon]Edit: Opens an editing sheet for the selected bookmark.
	[image: Icon]Delete: Deletes the selected items.
	[image: Icon]Show Icon Preview: When checked, DEVONagent Pro shows a preview icon for bookmarks.

	[image: Icon]Add Link to DEVONthink: Adds the link of the selected items to the currently open DEVONthink database. Only available if DEVONthink is installed on your Mac.
	[image: Icon]Copy Link: Copies the selected links to the clipboard.


Action menu 
The action menu (labeled with a gear icon) makes frequently used commands conveniently accessible from the toolbar.
	[image: Icon]Copy URL: Copies the address of the current page to the Clipboard.
	[image: Icon]Launch URL: Opens the selected pages in your default web browser.
	[image: Icon]Add to DEVONthink: Adds the pages to your currently open DEVONthinkdatabase in a variety of formats. Same as Data > Add to DEVONthink. Only available if DEVONthink is installed on your Mac.
	[image: Icon]Add to Set > ...: Adds the URL of the page to the "Sites" tabof the search set you select from the sub-menu. Select "New Set..." to create a new search set with the selected page(s).
	[image: Icon]Add to Archive: Adds the page to the internal archive.
	[image: Icon]Save As: Saves the the selected pages as pure text, RTF(D) or HTML.
	[image: Icon]Inverse Appearance: Inverts the colors of the results list to match it with Cover Flow. Uncheck to return to regular black-on-white appearance.


Shortcuts & modifier keys 
	[image: Icon]Command-click: Opens a link or an item in the objects drawer in a new tab, if tabbed browsingis enabled. Otherwise, ⌘-click opens the clicked link in a new window.
	[image: Icon]Option-click: Downloads an item on a webpage, a linked item or an item in the objects drawer via the download manager.
	[image: Icon]Space, Shift-Space: Scrolls down or up in non-editable text views, e.g., the source code or text-only view.


Context menu 
The context menu, which appears when you click something with the right mouse button or when you click while holding the ⌃ Control key down, offers a range of commands tailored to what you can do with the clicked object, for example a text passage.
Most of the commands offered by the context menu have counterparts in a main menu, so you'll recognize them immediately. However, to save menu bar real estate, DEVONagent Pro gives you access to some options only via the context menu.
	[image: Icon]Back/Forward: Navigates back and forth through previously visited pages, similar to the Back and Forward toolbar buttons or History > Back/Forward.
	[image: Icon]Reload: Reload the item or page.
	[image: Icon]Search in Spotlight: Searches selected text with Spotlight.
	[image: Icon]See Related Text: Opens the inspector with archived results related to the selected text passage.
	[image: Icon]Look Up in Dictionary: Looks up selected text in the system dictionary.
	[image: Icon]Stop Loading: Stops loading the item or page.
	[image: Icon]Open Image in New Window: Opens the selected image in a new web browser window.
	[image: Icon]Open Image in New Tab: Opens the selected image in a new tab of the current web browser window.
	[image: Icon]Open Image in PhotoStickies: Opens the selected image in  PhotoStickies.
	[image: Icon]Copy Image: Copies the selected image to the clipboard.
	[image: Icon]Copy Image Address: Copies the address or the selected image to the clipboard.
	[image: Icon]Add Image to DEVONthink: Adds the selected image to the currently open DEVONthink database. Only available if DEVONthink is installed on your Mac.
	[image: Icon]Add Image to Archive: Adds the selected image to the archive.
	[image: Icon]Save Image As...: Saves the selected image to your computer.
	[image: Icon]Save Image to Downloads: Saves the selected image to the default download folder.
	[image: Icon]Use Image as Desktop Picture: Saves the selected image and sets it as the desktop picture.
	[image: Icon]Open Link in New Window: Opens the selected link in a new web browser window.
	[image: Icon]Open Link in New Tab: Opens the selected link in a new tab.
	[image: Icon]Open Link in PhotoStickies: Opens the selected link in PhotoStickies.
	[image: Icon]Copy Link: Copies the selected link to the clipboard.
	[image: Icon]Download Linked File: Downloads the file referred to by the selected link via the Download Manager.
	[image: Icon]Share: Shares the selected item using OS X's standard share mechanism (requires at least OS X Mountain Lion).
	[image: Icon]Add Selection to DEVONthink: Adds the selected text to the currently open DEVONthinkdatabase. Only available if DEVONthink is installed on your Mac.
	[image: Icon]Add Link to DEVONthink: Adds the selected link to the currently open DEVONthinkdatabase. Only available if DEVONthink is installed on your Mac.
	[image: Icon]Add Link to Set > ...: Adds the selected link to the sites list of a search set.
	[image: Icon]Add PDF to DEVONthink: Adds the displayed PDF to the currently open DEVONthink database. Only available if DEVONthink is installed on your Mac.
	[image: Icon]Add page address to DEVONthink: Adds the address of the page to the currently open DEVONthink database. Only available if DEVONthink is installed on your Mac.
	[image: Icon]Add frame address to DEVONthink: Adds the address of the selected frame to the currently open DEVONthink database. Only available if DEVONthink is installed on your Mac.
	[image: Icon]Remember Selection: Remembers the current selection and re-applies it when you open the same page again.
	[image: Icon]Forget Selection: Forgets the last saved selection.

If the WebKit developer extras are enabled more options are available.
When you ⌃-click or right-click the background of the page instead of a item, additional options can be available:
	[image: Icon]Open Page/Frame in New Window: Opens the page or frame in a new web browser window.
	[image: Icon]Open Page in New Tab: Opens the page in a new tab.
	[image: Icon]Copy Page/Frame Address: Copies the address of the page or frame to the Clipboard.
	[image: Icon]Add Page/Frame to Archive: Adds the page or frame to the internal archive.
	[image: Icon]Add Page to DEVONthink (Pro): Adds the HTML code of the page to the currently open DEVONthink (Pro)database. Only available if DEVONthink is installed on your Mac.
	[image: Icon]Add Web Archive to DEVONthink (Pro): Adds an webarchive (including all embedded images needed for correctly displaying it) of the page to the currently open DEVONthink (Pro)database. Only available if DEVONthink is installed on your Mac.
	[image: Icon]Add Page/Frame to Set > ...: Adds the page or frame address to the sites list of a search set.
	[image: Icon]Add All Links to Set > ...: Adds all links found on the page to the sites list of a search set.

For PDF pages, different options become available:
	[image: Icon]Add PDF to DEVONthink: Adds the PDF to the currently open DEVONthinkdatabase. Only available if DEVONthink is installed on your Mac.
	[image: Icon]Open with Preview: Opens the PDF in Preview.
	[image: Icon]Automatically Resize: When checked, the zoom factor adjusts to the width resp. height of the browser window.
	[image: Icon]Zoom Out, Zoom In, Actual Size: Zooms in or out of the document, or displays it in its actual size.
	[image: Icon]Single Page, ...: Displays the PDF as single or double pages and either page by page (use the 'Next Page' and 'Previous Page' to skim through the pages forward and backwards) or continously.
	[image: Icon]Next Page, Previous Page: Skims through the pages forwards or backwards.

On the Results pane of the sidebar, the following additional options are available:
	[image: Icon]Mark As Read: Marks the selected pages as read or unread.



Archive window
[image: The archive window and its elements]
The integrated archive is where you can store found pages for later reference. Open the Archive window with Window > Archive.
The archive resembles the three panes view of Apple Mail or DEVONthink: The left pane shows a list of groups, the right top pane displays page titles and URLs in a selected group, and the right bottom pane displays textual information related to the query that was used for finding a selected page. A search field in the toolbar allows you to search the archive by content, name or URL.
Groups 
All archived pages are stored in groups. Groups are automatically created when you archive pages from the search window and are named after the search query. You can change group names at any time, delete groups or manually create new ones. You can also create sub-groups by selecting a group and then creating a new one. The number of items contained in a group is shown as a badge.
Note:
 Pages not related to a previous search run are archived in sub-groups of a top-level group named 'Incoming'. The sub-groups are named with the current date.
Create new groups by using the toolbar, the context menu or Data > New Group. Rename a group by clicking it once and waiting a second (like the Finder), or by selecting it and pressing the ↩ or Enter key. Delete a group by selecting it and pressing Backspace, using the toolbar, the context menu or Data > Delete. To make a group a sub-group, drag it with the mouse or use the context menu.
Sort the groups by name or date with Sort > by Name or Sort > by Date. Reverse the sorting order with Sort > Ascending/Descending.

Pages 
Like DEVONthink or Apple Mail, DEVONagent Pro shows the pages filed in a group when you select the group in the left pane. Select a page and DEVONagent Pro also shows a text preview in the lower right pane with the original search words highlighted.
Rename a page by single-clicking it and waiting a second (like the Finder), or by selecting it and pressing the ↩ or Enter key. Delete an item by selecting it and pressing Backspace, using the toolbar, the context menu or Data > Delete. To move an item to another group, drag it or use the context menu. Items can also be dragged to DEVONthink.
To sort the pages list, click the relevant (first), title, URL or date column header. Click again to reverse the sorting order. The relevance column is only used when you search the archive using the toolbar search field.

Toolbar 
The toolbar of DEVONagent Pro archive windows carries many commands for manipulating the way it displays information and for manipulating selected items. Many of them are simply shortcuts for menu bar commands. Here's a short list of the available tools:
	[image: Icon]Group +: Adds new groups to the archive. To create a sub-group, select the parent-to-be group first, then use this tool.
	[image: Icon]Open: Opens the selected page(s) in a separate web browser window.
	[image: Icon]Launch URL: Opens the selected page(s) in your default web browser.
	[image: Icon]Export: Exports the selected page(s) as pure text, RTF(D) or HTML.
	[image: Icon]DEVONthink (Pro): Adds the selected page(s) to the currently open DEVONthink (Pro) database. Only available if DEVONthink is installed on your Mac.
	[image: Icon]DEVONthink (Pro) pop-up: Adds the selected page(s) to the currently open DEVONthink (Pro) database, but allows you to select as HTML code or as a link via a pop-up menu. Only available if DEVONthink is installed on your Mac.
	[image: Icon]Delete: Deletes the selected page(s) from the results list.
	[image: Icon]Search: Searches the archive for entered text. Select whether you want to search the contents, the names or the URLs of the stored pages with the magnifying glass pop-up menu. Also choose whether to ignore diacritics or to search fuzzy. This search field also supports all operators and wildcards.
	[image: Icon]Print: Prints the results list.

Note:
 Not all of these commands are always available. You can customize the toolbar by selecting View > Customize Toolbar or by ⌃-clicking or right-clicking the toolbar background and selecting Customize Toolbar from the context menu.

Shortcuts & modifier keys 
Like any Mac application, DEVONagent Pro uses modifier keys or shortcuts to quickly access frequently used functions or modify a standard behavior.
	[image: Icon]Command-click: Adds an item to the current selection of items.
	[image: Icon]Shift-click: Selects a range of items.


Context menu 
The context menu, which appears when you click something with the right mouse button or when you click while holding the ⌃ Control key down, offers a range of commands tailored for what you can do with the clicked object.
Most of the commands offered by the context menu have counterparts in a main menu, so you'll recognize them immediately. However, to save menu bar real estate, DEVONagent Pro gives you access to some options only via the context menu.
	[image: Icon]New Group: Adds a new group to the archive. To create a sub-group, select the parent-to-be group first, then use this command. (Only available in the left pane)
	[image: Icon]Open: Opens the selected pages in separate web browser windows.
	[image: Icon]Open In Tabs: Opens the selected pages in separate tabs in a new web browser window.
	[image: Icon]Launch URL: Opens the selected pages in your default web browser.
	[image: Icon]Copy URL: Copies the selected URL to the clipboard.
	[image: Icon]Reveal in Finder: Reveals an externally archived page in the Finder.
	[image: Icon]Add to DEVONthink: Adds the selected pages to DEVONthink. Only available if DEVONthink is installed on your Mac.
	[image: Icon]Add to Set...: Adds the URLs of selected pages to the sites list of a search set so that it will get scanned when you use that search set in the future.
	[image: Icon]Move To > ...: Moves the item to the group you select from the sub-menu.
	[image: Icon]Export: Exports the selected pages.
	[image: Icon]Delete: Deletes the selected pages from the results list.
	[image: Icon]Delete Domain: Deletes all pages from the selected domains from the result list.
	[image: Icon]Delete & Exclude Domain: Deletes the selected search pages from the results list and adds the domains of the pages to the list of excluded domains. Use this to quickly exclude an unwanted domain without having to block it via the preferences. Alternative menu item to Delete Domains.
	[image: Icon]Sort by > ...: Sorts the results list by the criteria listed in the sub-menu.



Search sets
The Search Set window is available via Window > Search Sets. Use it to modify the existing search sets or to create new ones specifically tailored for your needs.
Because search sets are so important, we have created a separate chapter about the search sets and the search sets editor. [Read more...]

Plugins and scanners
The Plugins & Scanners panel, available via Window > Plugins & Scanners, lists all installed plugins and scanners and shows additional information about them, e.g., their type, version and purpose. In addition, it allows you to create new plugins for your favorite websites and search engines.
[image: Plugins & scanners]
Also, you can enable or disable plugins or whole groups of plugins by checking or unchecking them. Use this to simplify the magnifying glass pop-up menu in the search window or the plugin list in the Search Sets window.
Plugins & Scanners 
All plugins and scanners are arranged in groups. Click the grey triangle in front of a group to expand it; click it again to close it. Select a plugin or scanner to show additional information:
	[image: Icon]Name: Plugin name.
	[image: Icon]Info: Additional information, e.g., copyright.
	[image: Icon]Identifier: Internal and identification string.
	[image: Icon]Keywords: Shortcuts for the plugin. [Read more...]
	[image: Icon]Description: Textual description of the plugin.
	[image: Icon]Operators: List of supported operators. For plugins that you created yourself, you can check and uncheck them to adjust which operators are supported by the search engine.

Name, info, identifier, description, and keywords of self-made XML plugins can be edited. User-defined plugins, as well as the groups Browser, DEVONsphere, and Scanner are shown in bold.
Note:
 The group hierarchy is predefined and cannot be manually altered. If you have installed your own plugins, they appear in the top level of the hierarchy or are mirrored-in following the folder structure in '~/Library/Application Support/DEVONagent/Plugins/'.

Keywords 
Keywords are shortcuts that you can use to query the search engines defined by the plugin from the address bar of a web browser window.
Example: 
The Bing plugin comes with the predefined keyword 'bing'. To send a query to Bing, type e.g., 'bing devonthink' into the address bar of a DEVONagent Pro web browser window and press ↩ or Enter.
This effectively replaces the search engine field that is found in other web browsers, such as Safari, with a far more flexible approach. You can add your own keyword(s) to most plugins, separated by spaces, to make them quickly accessable from any open DEVONagent Pro browser window.
In addition, the plugin's name is automatically used as a keyword.

Creating & testing 
Using DEVONagent Pro's built-in plugin assistant, you can easily create your own XML-based search plugin for your favorite search engine. To create your own plugin, choose File > New Plugin or use the New toolbar icon.
In the sheet enter:
	[image: Icon]Name for the plugin
	[image: Icon]Short description
	[image: Icon]Website or search engine URL

To get the URL for your search engine, run a search in your web browser, copy the URL, and paste it into the URL field of the to-be-created plugin. Then look for the URL parameter that transports the query, e.g., something like '&query=xxx'. Replace 'xxx' with '_agentQuery_'. This tells DEVONagent Pro where to enter the search term. The '_agentNumber_' and '_agentOffset_' placeholders are automatically inserted if necessary and possible. [Read more...]
Alternatively, if you want to create a plugin that simply searches a website, enter just the URL of the website. DEVONagent Pro will use standard search engines such as Bing to run a site-specific search when you use this plugin.
DEVONagent Pro selects the Website or Search Engine radio buttons automatically, depending on the entered URL.
To test a build-in or self-created plugin use the Test toolbar icon. DEVONagent Pro will send 'Test' as the standard search term to the plugin and present you with the list of returned pages. Double-click results to view them in a new web browser window. Only XML and JSON plugins using 'EngineUrl' can be tested since testing XML and JSON plugins using 'EngineSite' is unnecessary.
To edit an existing XML- or JSON-based plugin, double-click it or use the Edit toolbar icon. DEVONagent Pro shows an XML text editor with error checking that allows you directly edit the source code of the plugin. Switch between XML and JSON format using the button at the bottom of the editing sheet. [Read more...]

Toolbar 
The toolbar of the Plugins & Scanners windows lets you easily create new plugins, edit, test, and delete them.
	[image: Icon]New: Opens a sheet for creating a new XML-based plugin.
	[image: Icon]Edit: Opens a sheet for editing the XML code of the selected plugin.
	[image: Icon]Test: Runs a test on the selected plugin and displays the results.
	[image: Icon]Delete: Deletes the selected plugins. Built-in plugins cannot be deleted.
	[image: Icon]Show In Finder: Opens a new Finder window for the folder containing the selected plugin.


Context menu 
The context menu, which appears when you click something with the right mouse button or when you click while holding the ⌃ Control key down, offers a range of commands tailored for what you can do with the clicked object, forexample a text passage.
	[image: Icon]New: Opens a sheet for creating a new XML-based plugin.
	[image: Icon]Edit: Opens a sheet for editing the XML code of the selected plugin.
	[image: Icon]Duplicate: Duplicates the selected plugins.
	[image: Icon]Show In Finder: Opens a new Finder window for the folder containing the selected plugin.
	[image: Icon]Test: Runs a test on the selected plugin and displays the results.
	[image: Icon]Delete: Deletes the selected plugins. Built-in plugins cannot be deleted.

The test sheet also presents the following options in the context menu:
	[image: Icon]Open: Opens the selected URLs in DEVONagent Pro's built-in web browser.
	[image: Icon]Open In Tabs: Opens the selected URLs in separate tabs in DEVONagent Pro's built-in web browser.
	[image: Icon]Launch URL: Opens the selected URLs in the default application for their types.
	[image: Icon]Exclude URL: Adds the selected URLs to the plugin's internal exclude list. Use Retry to re-run the test after exluding a URL.
	[image: Icon]Exclude Domain: Adds the domains of the selected URLs to the plugin's internal exclude list. Use Retry to re-run the test after exluding a domain.
	[image: Icon]Include URL: Adds the URL to the "LinksMatching" key.
	[image: Icon]Include Domain: Adds the domain to the "LinksMatching" key.
	[image: Icon]Copy: Copies the selected URLs to the clipboard.



Downloads
Window > Downloads opens the Downloads window. Use it to download files from the Internet to your computer. The download URL is automatically placed into the Finder comment of the downloaded file, as well as in the 'kMDItemWhereFroms' extended file system attribute.
[image: The Downloads panel]
For URLs that require authentication, DEVONagent Pro asks for a username and password. It also uses the systemwide cookies, and can start and stop downloads at any time.
Adding, resuming, retrying 
To add files to the Download Manager, drag a link to the item from any DEVONagent Pro web browser window or any other application to the Download Manager window, paste a copied URL or ⌃-click a link in a DEVONagent Pro web browser window and choose "Add to Download Manager". ⌥-clicking links in the web browser or the objects drawer adds items to the Download Manager, too. Also, DEVONagent Pro automatically puts files it cannot display into the Download Manager, if you double-click them, e.g., .zip archive files.
DEVONagent Pro downloads files added to the Download Manager immediately. To remove a file, select it and click the - button at the bottom of the window. To temporarily prevent an item from being downloaded, uncheck the checkbox in front of it. Check the checkbox to download the item. Use this to add items to the download queue, but download them later.
To resume or retry a failed download, select the file and click the back arrow button. Use the start/stop button (resembles the start/pause button of a VCR or tape player), to start or stop the entire queue.
You can also drag items from the Download Manager to other windows or to the Finder, or copy it to the Clipboard. Drag-and-drop will send the URL of the item to the target window or application.
DEVONagent Pro puts the web address where the file was downloaded from into the Spotlight comments of the file (not available if DEVONagent Pro was purchased in the Mac App Store).

Action menu 
The action menu provides the same options as the context menu.

Context menu 
The context menu, which appears when you click something with the right mouse button or when you click while holding the ⌃ Control key down, offers a range of commands tailored to what you can do with the clicked object.
	[image: Icon]Cut: Copies the selected link to the Clipboard and removes it from the queue.
	[image: Icon]Copy: Copies the selected link to the Clipboard.
	[image: Icon]Paste: Adds a link that is copied to Clipboard to the download manager queue.
	[image: Icon]Retry: Retries a stopped or stalled download.
	[image: Icon]Show In Finder: Opens a Finder window for the enclosing folders of the selected items.
	[image: Icon]Enable/Disable: Enables or disables the selected item(s). Disabled (unchecked) items are not downloaded but kept in the download queue.
	[image: Icon]Reload: Reloads the selected items.
	[image: Icon]Remove: Removes the selected items from the queue.
	[image: Icon]Start/Stop Queue: Starts or stops the download queue.
	[image: Icon]Purge Queue: Purges all completed items from the queue.
	[image: Icon]Automatically Purge Queue: When checked, completed items are automatically purged from the queue.



Preferences
The Preferences window is available via DEVONagent Pro > Preferences. It contains all available options that you can modify to adapt DEVONagent Pro to your personal needs.
Because the preferences are so important, we have created a chapter just for them. [Read more...]

Assistant
The integrated Assistant combines a welcome screen with tips, tricks, and tutorials, installable extras, and a suppport page that guides you through the available support options.
Click here [special link, not enabled in ebook] to directly open the assistant.
[image: ]
Welcome 
This screen welcomes you when you start DEVONagent Pro for the very first time. It offers:
	[image: Icon]The option to subscribe to the free DEVONtechnologies newsletter
	[image: Icon]The tip of the day
	[image: Icon]The extra of the day

You can access all other screens of the assistant from here, too.

Get support 
The support screen guides you through the three common steps for troubleshooting DEVONagent Pro. In addition you can have your license code resent, request a trial extension, update your details in DEVONtechnologies' customer database, or buy an upgrade or a second license.

Tips and tutorials 
Here you can always find the latest tips sand tutorials that help you squeeze the best out of DEVONagent Pro. Tutorials can be slideshows describing basic tasks in DEVONagent Pro or videos (as they become available).
Both tips and tutorials are updated live from DEVONtechnologies' server, so it's a good idea to check back from time to time. The latest tip or tutorial is always mentioned on the welcome screen.

Install extras 
[image: ]
On the extras screen, DEVONagent Pro lists available extras that you can download and install from DEVONtechnologies' server:
	[image: Icon]Scripts
	[image: Icon]Plugins
	[image: Icon]Search Sets

Browse the list of extras and install them with the Install button. The last line of the description shows where in the Scripts menu or Plugins hierarchy the extra will show up after installation. Remove installed extras with the Remove button. Check Install and update extras automatically to receive all new extras and have them updated without visiting the window regularly yourself.
The extras are updated live from DEVONtechnologies' server so it's a good idea to check back from time to time. The latest extra is always mentioned on the welcome screen.
Note:
 If one of these categories does not show up in your copy of DEVONagent Pro, there may not be extras of this type available yet for DEVONagent Pro.


Preferences
The preferences window, which you open by selecting Preferences in the DEVONagent Pro menu, is the place where you change all global settings of DEVONagent Pro. Click here [special link, not enabled in ebook] to open the Preferences window.
For your convenience, the preference panel is divided into tabs, just like System preferences. Use the icons at the top of the preferences window to select the tab you want to check or modify.
General
[image: Preferences, General Tab]
This tab contains all options modifying the user interface and the summarization of search results.
Interface 
These options define some parts of DEVONagent Pro's visual appearance.
	[image: Icon]Highlight occurences in HTML pages: Check to highlight occurences of search words in web browser windowsor views.
	[image: Icon]Automatically zoom search panel: Check to open new search windowssimplified.
	[image: Icon]Floating simplified search panel: Makes the simplified search windowfloat above all other windows. Use this to have the search window always handy.
	[image: Icon]Alternating rows colors in views: When checked, DEVONagent Pro colors lines in lists differently to make them easier to read.


Alerts 
Click Reset to make DEVONagent Pro show alerts again that you previously dismissed with "Don't show again" checked.

Search Panel 
This option defines which tab DEVONagent Pro shows when a search run is done.
	[image: Icon]Digest: Switches to the Digest tab when DEVONagent Pro has finished a search run.
	[image: Icon]Results: Switches to the Results tab when DEVONagent Pro has finished a search run.
	[image: Icon]Log: Switches to the Log tab when DEVONagent Pro has finished a search run.
	[image: Icon]Settings: Switches to the Settings tab when DEVONagent Pro has finished a search run.


Summarization 
These options define how DEVONagent Pro creates summaries.
	[image: Icon]Based on sentences: Creates summaries based on sentences. These are generally shorter summaries, so you may miss information that DEVONagent Pro classifies as not important.
	[image: Icon]Based on paragraphs: Creates summaries based on whole paragraphs. These are longer summaries that are not clipped.


Startup 
These options let you define what DEVONagent Pro does when you open it.
	[image: Icon]Open new query: Opens a new, empty search window when you open DEVONagent Pro.
	[image: Icon]Open new browser: Opens a new web browser window when you open DEVONagent Pro.
	[image: Icon]Open browsers that were open on quit: Opens the web browser windows that were open on quit.
	[image: Icon]Do nothing: Does nothing when you open DEVONagent Pro.


Home page, ... 
These options define the default home page and the folder for downloaded files.
	[image: Icon]Home page: Sets the home page that is loaded automatically each time you open a new web browser window.
	[image: Icon]Save downloaded files to: Sets the folder into which DEVONagent Pro saves downloaded files. [Read more...]


Fonts 
Define the fonts you want to use for searching and reading texts. Click the Select buttons to open the standard font panel. Hold the ⌥ Option key to reveal options for resetting the fonts to the defaults.
	[image: Icon]Source font: Changes the font used for displaying source code. A monospaced font, such as Courier or Monaco, gives you the best results.
	[image: Icon]Text font: Changes the font used for displaying plain text, e.g., text extracted from webpages.



Search
Contains all options dealing with the cache, the number of connections, and domains excluded from searching.
[image: Preferences, Search Tab]
General 
	[image: Icon]Ignore instructions for robots: Ignores instructions embedded into the HTML code of webpages that tell robots (like DEVONagent Pro) to not index a page. If unchecked (default setting), DEVONagent Pro tries to honor the wishes of the webpages creator.
	[image: Icon]Cache downloaded pages: Check if you want DEVONagent Pro to store downloaded pages in its cache. This consumes disk space, but leads to much faster searches when DEVONagent Pro scans an already cached page.
	[image: Icon]Clear on quit: When checked, DEVONagent Pro clears the cache upon quit.
	[image: Icon]Cache Directory: Shows the path to the folder used by DEVONagent Pro for its cache. Double-click an item to reveal it in the Finder or select another folder for DEVONagent Pro to use.


Create Previews 
Choose whether DEVONagent Pro should create previews of visited or found pages immediately or on demand, and set how DEVONagent Pro generates thumbnails of webpages.
	[image: Icon]Immediately: Previews are created and cached immediately.
	[image: Icon]On demand: Previews are created and cached only when needed (default).
	[image: Icon]Directly: DEVONagent Pro generates thumbnails itself (higher quality).
	[image: Icon]Via DEVONtechnologies.com: Generates web page thumbnails via web service (faster).

Note:
 DEVONagent Pro never sends more than just the URLs of the to-be-thumbnailed webpages to Thumbshots.com.

Max. Connections 
Use this parameter to adjust the number of connections DEVONagent Pro uses concurrently so as to match the speed of your Internet connection and your computer.

Max. Download Size 
Choose how large files can be that DEVONagent Pro downloads in search runs. Adjust this to your Internet connection speed. Files skipped due to file size are marked as "Too big" in the log tab of the search window.

Exclude Domains, ... 
Exclude Domains: Enter all domains you want to exclude from searching in this text field, separated by returns. Use this to exclude domains blocking automatic bots like DEVONagent Pro, e.g., 'sciencemag.org' or 'slashdot.org', or to ignore sites you don't like. Domains skipped because they match one or more entries in this list are marked as 'Skipped' in the Log tab of the Search window.
Exclude Links: Enter URLs you want to exclude from being searched.
Note:
 Both fields also accept the '*' wildcards at the beginning or end of lines.


Menu extra
The options in this tab determine if DEVONagent Pro's menu extra is automatically started when you log into your account, if the menu should show icon previews, how results are opened when selected, and what hotkey to use to call the menu.
[image: Preferences, Menu Extra Tab]
General 
	[image: Icon]Start at login: The menu extra is started automatically when you log in.
	[image: Icon]Show icon preview: Shows preview icons of the found pages in the menu.
	[image: Icon]Show text summary in menu: Shows a short summary directly in the menu. Uncheck this option to keep the menu less crowded; you can always read the full summary in the tooltip.
	[image: Icon]Cancel search after opening a result: Stops the search run as soon as you double-click a result to view it. This option has no effect when you open the result in the background.


Search 
	[image: Icon]Agent: Downloads each result page and filter e.g. error pages.
	[image: Icon]Express: Returns the results unfiltered.

In both cases DEVONagent Pro uses its unique artificial intelligence technology to rank the results, in Express mode only based on title, address, and a short summary, in Agent mode based on the full text of the page.

Open Results 
	[image: Icon]In DEVONagent Pro: Results you select in the menu extra's menu are opened using DEVONagent Pro's browser.
	[image: Icon]In default web browser: Results you select in the menu extra's menuThe results are opened using your default web browser.


Hotkey 
Click the button to record any key combination you like to call the menu extra. Using the hotkey will open the menu extra in OS X 10.7 Lion's fullscreen mode, too.


Web
The options in this tab resemble the settings of most web browsers. They define how DEVONagent Pro's built-in web browser windows displays HTML documents and live webpages.
[image: Preferences, Web Tab]
Web Content 
These settings define how DEVONagent Pro treats special Web contents.
	[image: Icon]Enable plugins: Check this option to use installed third-party plugins, e.g., Flash or RealPlayer.
	[image: Icon]Enable Java: Check this option to run Java applets contained in or linked to webpages.
	[image: Icon]Enable JavaScript: Check this option to run JavaScript scripts contained in webpages.
	[image: Icon]Block pop-up windows: Check this option to block pop-up windows, which are often advertisements. Uncheck this option if the webpage you're visiting uses pop-up windows for actual content (which ome Web content management systems do).
	[image: Icon]Only automatic JavaScript windows: Check this option to block only pop-up windows opened by JavaScript, instead of all pop-ups.
	[image: Icon]Block zooming: Check this option to keep JavaScript from zooming the web browser window to full screen.
	[image: Icon]Block advertisment: Check this option to block common inline advertisements provided by major search engines.
	[image: Icon]Zoom text only: Check to scale only the text when zooming in and out of webpages. If unchecked, DEVONagent Pro uses Safari-4-style zooming.


Images 
Use these otions to define how DEVONagent Pro displays graphics in webpages.
	[image: Icon]Display images when the page opens: Check this option to diplay webpages with images or uncheck to load them without images. If unchecked, you may miss some information on graphic-oriented pages.
	[image: Icon]Animate images: Check this option to run animated graphics; uncheck it to show the items statically.
	[image: Icon]Loop animations of images: Check this to run animated graphics in a loop.


Accept Cookies 
Cookies are little text files with information that webpages store on your computer to recognize you as a returning customer. While most cookies are harmless, you may want to control what is being stored on your hard disk.
	[image: Icon]Always: Accepts all cookies.
	[image: Icon]Never: Doesn't accept any cookies
	[image: Icon]Only from sites you navigate to: Accepts cookies, but only from websites you navigate to, not from other sites, e.g., ad trackers.
	[image: Icon]Delete cookies on quit: Deletes all stored cookies when you quit DEVONagent Pro.

Note:
 Delete cookies on quit deletes the cookies for all WebKit-based web browsers including Safari. All these browsers use the same single cookie file.

Standard/Fixed-width font 
Set the font you want to use for displaying webpages separately for variable-width and fixed-width text. Holding the ⌥Option key changes the Select buttons to Reset for resetting the font to the factory default.

(Feed) Style Sheet 
You can further control the way DEVONagent Pro displays webpages by applying a CSS style sheed for changing the rendering on-the-fly.
	[image: Icon]Style Sheet: Click Select and choose your own style sheet to apply it.
	[image: Icon]Feed Style Sheet: DEVONagent Pro comes with a number of different style sheets for Atom/RSS/JSON news feeds. Choose your preferred style. You can use your own CSS styles for news feeds by placing them in '~/Library/Application Support/DEVONagent/StyleSheets' (restart DEVONagent Pro if necessary).

Note:
 Applying an external CSS style sheet to webpages is an expert option. It heavily affects the rendering of all webpages in DEVONagent Pro, though it does not interfere with the search functionality of DEVONagent Pro.

Text Encoding 
Select your desired text encoding for displaying webpages. Generally the default setting, Automatic should work fine. If not, choose a more appropriate text encoding for your language.

WebKit Developer Extras 
Enable to use the standard WebKit developers extras in web browser, e.g., the element inspector or the JavaScript console.


Tabs
Like many modern web browsers, DEVONagent Pro features tabbed browsing. This enables you to display multiple webpages in one web browser window and switch between them with tabs.
[image: Preferences, Tabs Tab]
Use the following settings to activate tabbed browsing and define additional options. They resemble those available in Apple Safari.
	[image: Icon]Open links from applications: Defines whether DEVONagent Pro shows pages requested by other applications, such as the Finder, in a new window or in a new tab in the current web browser window.
	[image: Icon]Enable Tabbed Browsing: Switches tabbed browsing on or off. You can always create new tabs manually, but DEVONagent Pro will not open new tabs automatically or when you ⌘-click a link.
	[image: Icon]Select new tabs as they are created: When checked, DEVONagent Pro automatically switches to a newly generated tab.
	[image: Icon]Always show tab bar: When checked, the tab bar is always visible; when unchecked, DEVONagent Pro only shows the tab bar when at least two tabs are open.

Note:
 The lower part of the preference window shows the keyboard commands for creating new tabs and opening links in new tabs, similar to Apple Safari. The keyboard commands may change with the options you select above.

Bookmarks
DEVONagent Pro makes the bookmarks defined in your favorite web browser available both in the Go menu and in a bookmark drawer in web browser windows.
[image: Preferences, Bookmarks Tab]
Bookmarks 
Select your favorite browser:
	[image: Icon]Camino
	[image: Icon]DEVONagent Pro
	[image: Icon]Firefox
	[image: Icon]Chrome
	[image: Icon]OmniWeb
	[image: Icon]Safari

DEVONagent Pro comes with its own bookmark management. Choose DEVONagent Pro in the list to use the integrated bookmark management. [Read more...]

Bookmarks bar 
Select whether DEVONagent Pro automatically mirrors Web servers announced via Bonjour, bookmarks stored in DEVONthink Pro, and workspaces in the bookmarks pane in a web browser windows sidebar or the Go menu.
	[image: Icon]Include Bonjour: List Web server announced via Bonjour.
	[image: Icon]Include DEVONthink: List bookmarks from open DEVONthink databases. The bookmarks are retrieved when DEVONagent Pro starts up. Since they are cached, they remain available even when DEVONthink isn't open.
	[image: Icon]Include Workspaces: List workspaces.


Bookmarks menu 
Select if you want to include Bonjour services in the Go menu.
	[image: Icon]Include Bonjour: List Web servers announced via Bonjour in Go menu.



Email
DEVONagent Pro can send you reports of schedules search runs by email. Tell DEVONagent Pro how it shall send you messages on this tab.
[image: Preferences, Email Tab]
Send Email 
Choose if you want DEVONagent Pro to send you email using Apple Mail or using the built-in email function. If you don't use Apple Mail, add your email account details:
	[image: Icon]Server Name: Your SMTP server address
	[image: Icon]User: Your SMTP user name
	[image: Icon]Password: Your SMTP password
	[image: Icon]Port: The port to use; usually the default port should work
	[image: Icon]SSL: Check if you want to use a secure connection


Email Font 
Set the font used for styled emails (rich text). Check Send styled emails to let DEVONagent Pro send summary emails as RTF text. Read more about sending summary email messages here.


Update
Change the settings on this tab to choose when you want DEVONagent Pro to check for new versions: never, on startup, daily, weekly or monthly. DEVONagent Pro only checks for updates when the computer is connected to the Internet.
[image: Preferences, Update Tab]
Click Check Now to immediately check for a new version.
Note:
 This feature is not available when DEVONagent Pro was purchased through the Mac App Store.

Menu extra
DEVONagent Pro adds a [image: ] menu extra to the right-hand side of the menu bar that allows you to enter a query and search run at any time from the menu bar.
[image: Menu Extra]
It looks similar to the Spotlight menu and works pretty much the same way:
	[image: Icon]Choose a search set or plugin from the magnifying glass pop-up menu.
	[image: Icon]Enter your query.
	[image: Icon]Hit ↩ or Enter.

DEVONagent Pro runs the query and shows the results in the menu.
	[image: Icon]A colored bar in the search field shows search progress.
	[image: Icon]Point with the mouse at any result to show a tooltip with a preview and a text summary.
	[image: Icon]Click the result to open it in DEVONagent Pro or your default browser. [Read more...]
	[image: Icon]Hold the ⌥ or ⌘ modifier key to open results in the background.
	[image: Icon]Drag results to the Desktop or other applications. Dragging to the Desktop creates bookmarks (.webloc); dragging to other applications inserts the web address.
	[image: Icon]Navigate through the list with the Up and Down keys, press ↩ or Enter to open the result in your browser.
	[image: Icon]Recall recent searches or recently used plugins or search sets from the magnifying glass [image: ] pop-up menu.
	[image: Icon]Click the [image: ] to clear your search.

Scripts
DEVONagent Pro comes with a fully loaded AppleScript dictionary and several Automator actions that help you automate almost every aspect of your DEVONagent Pro workflow. Use the included scripts to perform regular tasks and as templates for creating your own scripts and Automator workflows.
Introduction
DEVONagent Pro features an AppleScript dictionary and Automator actions that automate the application and integrate it with almost every other application supporting AppleScript and Automator.
Example scripts 
To make it easier for you to start using and writing scripts, we deliver a slew of scripts with DEVONagent Pro that you can access in the Scripts menu (which shows a stylized S symbol as its title instead of the word Scripts). These scripts interact directly with selected items, the currently displayed webpage or a window. All scripts delivered with DEVONagent Pro are useable in your daily work and don't require modification.

Integrating other applications 
In addition to the scripts that you use inside DEVONagent Pro, OS X features a global script menu that allows you to access certain scripts from any application on your Mac, e.g., your web browser or Apple Mail. When activated, the global script icon appears at the right side of the menu bar (like other menu extras such as the AirPort signal strength or the Spotlight icon). It appears with a black stylized S icon.
Note:
 By using folders named after applications inside the '~/Library/Scripts/Applications' directory, it is also possible to make scripts application-specific. Such scripts will appear at the top level of the global script menu when the application they belong to is frontmost. This removes clutter and shows only scripts that make sense in the current application.
DEVONagent Pro does not come with scripts for other applications, but you can use the global script menu for creating application-specific scripts.
To activate the global script menu, do the following:
	[image: Icon]Open the AppleScript Utility (located in '/Applications/AppleScript').
	[image: Icon]Check Show Script Menu in menu bar.
	[image: Icon]Uncheck Show Library scripts if you only want to see the scripts you have installed yourself.

To install your own scripts, copy them into the folder '~/Library/Scripts'. You can use subfolders to structure them in any way you like.

DEVONagent Pro's dictionary 
DEVONagent Pro includes a large dictionary with commands, objects, and methods you can use for writing scripts that interact or extend DEVONagent Pro. To view the dictionary, open the Script Editor application (by default located in '/Applications/AppleScript'), select File > Open Dictionary and choose DEVONagent Pro in the window.
You can also add DEVONagent Pro to your Script Editor library. Select Window > Library, click the + button and choose DEVONagent Pro. This way you keep DEVONagent Pro's dictionary at hand.

Learning AppleScript 
This documentation is not an AppleScript language guide. Please refer to Apple's AppleScript website, other online resources, or introductory and reference books for more information on the AppleScript language. Here are some links for you:
	[image: Icon]The Ultimate Beginner's Guide to AppleScript
	[image: Icon]MacScripter
	[image: Icon]ScriptWeb
	[image: Icon]Scripting Matters Trainings

	[image: Icon]AppleScript for Absolute Starters (free PDF book)
	[image: Icon]AppleScript: The Missing Manual
	[image: Icon]AppleScript: The Definitive Guide



DEVONagent Pro's Scripts menu
The internal scripts menu of DEVONagent Pro, located to the left of the Help menu, gives you access to pre-made scripts that extend DEVONagent Pro with additional, more specialized commands and functions. They are only visible from inside DEVONagent Pro.
[image: ${Software}'s Script menu]
Of course, you can easily modify all these scripts using AppleScript Editor, and the workflows using Automator. And you can add your own scripts and workflows--located in '~/Library/Application Support/DEVONagent Pro/Scripts'--to the menu. You can open this folder in the Finder using Scripts > Open Scripts Folder.
Keyboard shortcuts: If you want to add keyboard shortcuts to scripts in this menu, either use the System Preferences or add the shortcut description to the file name of the script in "~/Library/Application Support/DEVONagent Pro/Scripts" or "~/Library/Scripts". Example: "eMail Current URL (Mail)___Cmd-Alt-M.scpt". The naming convention is three underline characters followed by the shortcut description. "Cmd" stands for the ⌘Command, "Alt" for the ⌥Option, "Ctrl" for the ⌃Control, and "Shift" for the ⇧Shift keys.
Caching: All scripts in this menu are cached and therefore their properties are persistent until you quit and relaunch the application or DEVONagent Pro automatically updates the menu, e.g. after adding or removing scripts.
Note:
 If you have modified the contents of the script menu and want to go back to the default set, delete the Scripts folder in "~/Library/Application Support/DEVONagent/". DEVONagent Pro will recreate this folder, including it's content, the next time you launch the application.
Scripts interacting with other applications 
	[image: Icon]Email Current Page (Mail): Creates a new message in Apple Mail with the currently displayed webpage attached as webarchive. Webarchives contain the HTML code of the page including all embedded elements that are necessary to display them.
	[image: Icon]Email Current URL: Asks for an email address and sends the URL of the currently displayed webpage by email to this address. This script does not use Apple Mail, but sends the message directly via the messaging framework of OS X. It requires that you have set up at least one email account correctly in Apple Mail.
	[image: Icon]Email Results (Mail): Creates a new email in Apple Mail with the abstracts of all results in its body.


Scripts working with images 
	[image: Icon]Download Embedded JPEG Images: Downloads all JPEG images embedded into the currently displayed page to the default download location via the download manager.
	[image: Icon]Download Linked JPEG Images: Downloads all JPEG images linked from the currently displayed page to the default download location via the download manager.
	[image: Icon]Open Linked JPEG Images in Tabs: Opens all JPEG images linked from the currently displayed page in separate tabs, then closes the current tab.
	[image: Icon]Open Linked JPEG Images: Opens all JPEG images linked form from the currently displayed page in separate web browser windows.


Scripts working with pages and results 
	[image: Icon]Download Objects of Results: Downloads all found objects of the frontmost search window. The search needs to be run with an active scanner returning objects, e.g. Embedded Images.
	[image: Icon]Convert Results to RSS: Creates an RSS feed file for the found or selected results and puts it into ~/Sites/rss. Enable web sharing to easily view your feeds locally using your web browser by browsing to, e.g., http://127.0.0.1/rss/mysearchset.rss.
	[image: Icon]File Results in DEVONthink: Files new results in DEVONthink. One group is created for each search set/query. This script can is used as a search set action.
	[image: Icon]Speak Titles of Results: Speaks the titles of the found or selected pages.


Scripts for the toolbar 
By default this contains no scripts. Add your own scripts here and also add them to the toolbar of search and browser windows using View > Customize Toolbar.

Scripts arranging windows 
	[image: Icon]Open last Safari session: Opens the last Safari session in DEVONagent Pro.
	[image: Icon]Browsers Side-by-Side: Arranges the currently open web browser windows side-by-side.
	[image: Icon]Tile Browsers: Arranges the currently open web browser windows tiled to 800 pixel width.
	[image: Icon]Combine Windows: Combines the currently open web browser windows as separate tabs in one window.
	[image: Icon]Windows to Full Screen: Resizes all web browser windows to full screen.



Automator
DEVONagent Pro also comes with a bundle of integrated Automator actions you can use to create your own Automator workflows.
To see which actions DEVONagent Pro provides, open Automator and select DEVONagent Pro in the applications list on the left hand side. If you do not see DEVONagent Pro in the Library list, use View > Arrange Actions by > Application. Select any action to show a short description about what the action does, and have a look at Automator's built-in help to learn more about how to create a workflow.
Note:
 Cannot find the Automator action you need for your workflow? We're open to suggestions!

Plugin Development
DEVONagent Pro comes with a long list of ready-to-use plugins for popular search engines. However, DEVONagent Pro makes it possible to write your own plugins to query sites for which there isn't a built-in plugin provided. Here is all what you need. The tutorial gives you a jump-start on how to write your own plugins for DEVONagent Pro, e.g., for integrating a search engine we haven't thought of yet. And the XML and JSON keys descriptions explain all the XML tags/JSON keys you can use in developing the perfect plugin.
Creating Your Own Plugins
Do you have one or more favorite websites you would like to search using DEVONagent Pro? While the potential to create a bespoke plugin depends on the specific site, DEVONagent Pro has a built-in tool to aid in creating a site-specific plugin. This chapter guides you in using its integrated plugin assistant to create an XML plugin, walking you through a real-world, practical example.
Note:
 In addition to the information below, it would be good to also have a look at the Keys section of this chapter. There you can find a list of available the XML keywords and their descriptions.
 Now let's create a simple functional plugin from scratch!
Step 1 
Open a browser window for search.acs.org in DEVONagent Pro or any other web browser. Search for "mercury".
[image: ]
At the bottom of the results, Control-click the Next link and copy the link. Leave this window open while developing the plugin.

Step 2 
Choose File > New Plugin. This will open the Plugins & Scanners window. In the URL field, paste the copied link, and replace mercury in the URL with _agentQuery_. The _agentQuery_  placeholder is replaced with your search terms when using the plugin. An _agentOffset_ placeholder, used by DEVONagent Pro to jump from result page to result page, is automatically inserted since a start= parameter is present. This would also be used with other such parameters, like next=. Enter a name for the plugin and optionally, a description. The Search Engine radio button is automatically selected by DEVONagent Pro. Then press the Add button.
[image: ]

Step 3 
Let's test the plugin. Press the Test button at the top of the Plugins & Scanners window. The results show the created plugin is functioning but is causing unnecessary traffic and returning many unnecessary results. Select any unwanted links in the Log, e.g., Twitter, Facebook, mailto, etc. Control-click one, and choose Exclude Domain.
[image: ]
Also, select one of the links with search.acs.org in its URL and exclude that domain as well. This keeps search pages from becoming possible results. Note you can sort the results by location to help isolate results by location for easier handling. Then press the Retry button. You should see 10 links being reported for the search URLs in the log.
[image: ]

Step 4 
Now choose File > New Search. Select our new plugin from the options under the magnifying glass. Run a test search using the search term mercury. We are getting some results but more fine-tuning is needed for better returns.
When we examine the URL of the results in the browser window, we can see they are from www.acs.org/content. We can use this information to tell DEVONagent Pro to only match items from that domain. In the Plugins & Scanners window, double-click the new plugin. The code for  it will be displayed and ready for editing. Type these elements exactly as shown:

			<key>LinksMatching</key>

			<string>*www.acs.org/content*</string>
		Also make sure the OffsetPerPage key is set to 10. This ensures DEVONagent Pro will go the subsequent pages of results.
Running a new search, we get some results. We're not quite there but we are targeting the correct domain!
Now let's use another powerful set of keys: TextStart and TextEnd. These tell DEVONagent Pro to try and make its text matches within the boundaries you've set in the plugin.
[image: ]
If you have enabled Developer Extras in Preferences > Web, you can Control- or right-click parts of the rendered page, e.g., the title of the article, and choose Inspect Element. Also, select items in the markup in the developer tools and the item on the rendered page will be highlighted. Otherwise, you can select Web > Source to show the HTML  source and search for items in the content of the page. 
Inspect or find the title of the article. In this case, notice it's an <h1> element. Then scroll down and inspect or find the paragraphs after the main article.  We see this section <class="reference parbase"> but this may appear more than once on the page. Looking a little further down, we see a section using <div class="ui-nav">. As this is the only place this element appears and we feel confident the footer appears on each result page, we will use this value. Type these XML elements exactly as shown:

			<key>TextStart</key>

			<string>&lt;h1&gt;</string>

			<key>TextEnd</key>

			<string>&lt;div class="ui-nav"&gt;</string>
		Now let's give this another try. We rerun the mercury search again and this time it yields many more good results!
[image: ]

Further Finetuning 
We now have a working plugin for the acs.org site. You can check both the results and digest panes in the Search window to further fine tune your plugin. Below are some useful keys used to more accurately target elements or properties, e.g., the date, from the resulting pages.
	[image: Icon]TitleStart and TitleEnd: Extract the title of the article.
	[image: Icon]DateStart and DateEnd: Extract the article's date if the date is found in the document's content.
	[image: Icon]NoTopics: Suppress common topics that always occur for any search on a site.

As mentioned above, you can examine the HTML source code of results and try to find strings that can be used for these keys. When looking at the topics in the digest pane after you've done your searches, you can set the NoTopics list. Any word that should not be included as a topic can be added to this list. Select words to exclude in the Digest tab and press ⌘C to copy them. You can then paste them into a <string>, as one comma-delimited line, like so

				<key>NoTopics</key>

				<string>water, society, Washington</string>
			In other cases, you might also want to look at the source of the plugin and validate the values for Start, OffsetPerPage, and ResultsPerPage,  etc. You can also add a CrawlDelay key to slow the pace of contact with the search engine's servers. This can help avoid overloading it and make DEVONagent Pro appear to be a bit more like a human is searching. [Read more...]
In addition, DEVONagent Pro may not always be able to insert the _agentOffset_ and _agentNumber_ placeholders automatically. You might have to do this on your own; otherwise, only the first results page is used.
Finally, uncheck any operators the search engine doesn't support.

Congratulations 
With the steps described in this tutorial, you should be able to go through the steps of writing a plugin yourself. With a bit of practice, it is possible to write an optimized plugin that will deliver good results for DEVONagent Pro to work with. It might help to look at the additional plugins that already come with DEVONagent Pro before designing your own plugin. For the built-in plugins, Control- or right-click and duplicate a plugin. You can then open and inspect its internal code.
And remember: If you think your plugin is great for others, please share it with us!


Available Plugin Keys
Plugins created in DEVONagent Pro's Plugins & Scanners window, are saved in ~/Library/Application Support/DEVONagent/Plugins. The format of the plugin depends on whether you choose to edit the plugin in Plist (.xml) or JSON (.json) format. Optionally, you can work in an external application.  XML-based plugins can be created or edited in applications like BBEdit or even Apple's Xcode. JSON-based plugins are plain text and can be created and edited in any plain text editor, for example TextEdit. Externally created plugins should be saved with the proper file extension in the same location mentioned above.
When you create a plugin in the application, certain keys will be automatically added for you. Double-click the plugin in the Plugins & Scanners window to view and edit the keys. This is a good way to learn the internal structure and workings of a DEVONagent Pro plugin. It's easy to make changes and test them quickly using this window. However, you can use in an external editor, if you choose.
Listed below are the available keys, some required and some optional. Also, if the source to be processed is not HTML but XML or JSON output, there are specific keys that need to be used. Those are listed separately.
Boolean values are true or false and string values are case-insensitive.
Keys for HTML 
Required Keys:
	[image: Icon]Name: [string or dict] The name of the plugin. Example: BBC News.
	[image: Icon]Info: [string or dict] Information containing name, version and copyright. Example: BBC News Plugin 1.0 © 2003--2005 DEVONtechnologies.
	[image: Icon]Description: [string or dict] Describes the functionality of the plugin. Example: Queries the BBC news archive.
	[image: Icon]Version: [string] The version number (format major.minor). Example: 1.0.
	[image: Icon]Identifier: [string] Unique identifier (format domain.name.plugin). Example: com.devon-technologies.bbcnews.plugin.
	[image: Icon]EngineUrl: [string or array of strings] The Internet address(es) of the search engine. The strings _agentQuery_, _agentNumber_ and _agentOffset_ are replaced by the search term, the number of results and the offset of the current page. _agentNumber_ and _agentOffset_ are optional. _agentLanguage_ is replaced by the language used by the plugin (ISO 639 two-letter codes). Can contain the placeholders _agentUser_ and _agent_Password_ for HTTP authentication.

Example: 

				https://www.bbc.co.uk/cgi-bin/search/results.pl? tab=news&amp;start=_agentOffset_& go=homepage&amp;q=_agentQuery_.
			
Optional Keys:
	[image: Icon]CrawlDelay: [float] Specify a delay between two requests sent to the same server, defined in seconds.
	[image: Icon]DateEnd: [string or array of strings] String marking the end of the range of the HTML source code containing the date of a page.
	[image: Icon]DateStart: [string or array of strings] String marking the beginning of the range of the HTML source code containing the date of a page. Note that DateEnd is optional if DateStart is specified. Useful if server provides no dates or the wrong dates.
	[image: Icon]EncodingPage: [string] Default character encoding for result pages (default: Latin-1). Examples: ISO-8859-1, UTF-8, ISO-8859-2, Shift-JIS.
	[image: Icon]EncodingUrl: [string] Character encoding for search term _agentQuery_ (default: Latin-1). Examples: ISO-8859-1, UTF-8, ISO-8859-2, Shift-JIS.
	[image: Icon]EngineNextUrl: [string or array of strings] The Internet address(es) of the search engine(s) used for subsequent pages (if not identical to the address of the first page). The strings _agentQuery_, _agentNumber_ and _agentOffset_ are replaced by the search term, the number of results and the offset of the current page. _agentNumber_ is optional.
	[image: Icon]EngineRelated: [string] Defines a URL for a 'see also' function of the search engine.
	[image: Icon]EngineSite: [string or array of strings] Defines (a) (sub)domain(s) with or without a path to search. DEVONagent Pro uses an appropriate common search engine to perform the search. Example: devontechnologies.com/products/.
	[image: Icon]ExcludeLinksNamed: [array of strings] Defines an array of names of links which should be skipped.
	[image: Icon]FileTypes: [string] List of all supported file types: html, feed/rss, text, pdf, OpenOffice, Microsoft/Word, RTF or all. Default is all.
	[image: Icon]FilterLanguage: [Boolean] Enable or disable filtering by language.
	[image: Icon]FilterSimilarPages: [Boolean] Enable or disable DEVONagent Pro's Similar Pages filter (default: true).
	[image: Icon]FollowLinks: [Boolean] Enable or disable DEVONagent Pro's Follow Links option (default: true).
	[image: Icon]GoogleTags: [Boolean] Defines whether googleon/googleoff tags should be supported.
	[image: Icon]HTTPShouldHandleCookies: [Boolean] Defines whether cookies should be handled by HTTP or not.
	[image: Icon]Keyword: [string or array] One or more unique keywords used for quick searching (like "Mozilla Keywords") by entering the keyword followed by the search term in the URL field of the browser window.
	[image: Icon]KeywordsUrl: [string] Defines an alternate URL used for the Mozilla-like keywords in the browser's address bar.
	[image: Icon]LinksEnd: [string or array of strings] String marking the end of the range of the HTML source code containing the links to use (any position after the last link to use but before the next link). Example: -- Footer Area --.
	[image: Icon]LinksMatching: [string or array] Only links of result pages matching this string or these strings are used (prefix/suffix * wildcards are supported). Examples: *news.bbc.co.uk/*.
	[image: Icon]LinksNotMatching: [string or array] Only links of result pages not matching this string or these strings are used (prefix/suffix * wildcards are are supported).
	[image: Icon]LinksStart: [string or array of strings] String marking the beginning of the range of the HTML source code containing the links to use (any position before the first link to use and after the last link to ignore). Note that LinksEnd is optional if LinksStart is specified. Example: search results for.
	[image: Icon]LoginPost: [string] Defines the optional HTTP POST parameters. Usage like Post. Can contain the placeholders _agentUser_ and _agent_Password_.
	[image: Icon]LoginURL: [string] The address used to log into a website. Usage similar to "EngineUrl". Can contain the placeholders _agentUser_ and _agent_Password_.
	[image: Icon]NextLinkStart: [string] Defines the start of the range for the 'next results page' link.
	[image: Icon]NextLinkEnd: [string] Defines the end of the range for the 'next results page' link.
	[image: Icon]NextLinkName: [string] Defines the name of the link for the 'next results page' (instead of having to use NextLinkStart/NextLinkEnd).
	[image: Icon]NoTopics: [array or string] Array of strings or string containing separated words to ignore in the topics list. Add site specific words here.
	[image: Icon]OffsetPerPage: [integer] Increase for _agentOffset_ after every page (default: 1).
	[image: Icon]Operators: [integer] Bitmap describing the possibilities of the search engine and the required syntax (see below). The default value is 59 (1+2+8+16+32), meaning that AND, OR, NOT, phrases, and parentheses are supported.
	[image: Icon]OperatorsDictionary: [dict] A dictionary containing key-string pairs to convert the name of operators to a different name required by the search engine. Possible keys are AND, ANDNOT, OR, NOT, XOR, NEAR, BEFORE, AFTER, -.
	[image: Icon]ParseLinks: [Boolean] Parse and unify links of common search engines (Google, Yahoo, Bing) (default: false).
	[image: Icon]Post: [dict or string] Send a HTTP POST instead of a HTTP GET action using this form data. Note: The strings of the form data can contain _agentQuery_ and _agentNumber_ placeholders.
	[image: Icon]PostScan: [Boolean] Tell DEVONagent Pro to check if the retrieved pages match the search term (true), or to accept all (false) pages (default: true).
	[image: Icon]ResultsPerPage: [integer] Number of results per page and maximal value for _agentNumber_ (default: 10).
	[image: Icon]RequiresCrawling: [Boolean] Marks this plugin as needing crawling.
	[image: Icon]RequiresThumbnails: [Boolean] Marks this plugin as using only thumbnailed links. Crawling needs to be skipped.
	[image: Icon]RoundResultsPerPage: [integer] Always round number of results per page (_agentNumber_) to multiples of this value (default: 10).
	[image: Icon]ScanTerm: [string] String specifying a term used to filter results (e.g. instead of or in addition to the secondary query defined by the user).
	[image: Icon]SkipsCrawling: [Boolean] Marks this plugin as skipping crawling.
	[image: Icon]Start: [integer] The initial value for _agentOffset_ (default: 0).
	[image: Icon]StripTags: [array] Array of strings marking HTML tags defining blocks to strip.
	[image: Icon]TextEnd: [string or array of strings] String marking the end of the range of the HTML source code containing the relevant text of a page. TextStart is optional if TextEnd is specified.
	[image: Icon]TextStart: [string or array of strings] String marking the beginning of the range of the HTML source code containing the relevant text of a page. Note that TextEnd is optional if TextStart is specified. Useful if you're querying a specific site (all results have the same layout) to skip headers, footers or navigation of a page. This improves plain text display, digest and summarization.
	[image: Icon]TextTags: [array] Array of strings marking HTML tags defining blocks to convert to text.
	[image: Icon]Timeout: [integer] Sets the timeout for requests; default is 60 seconds.
	[image: Icon]TitleEnd: [string or array of strings] String marking the end of the range of the HTML source code containing the title of a page.
	[image: Icon]TitleStart: [string or array of strings] String marking the beginning of the range of the HTML source code containing the title of a page. Note that TitleEnd is optional if TitleStart is specified. Only useful if all results have identical or no titles (for example a Usenet query).
	[image: Icon]UseListingResults: [Boolean] Treat the returned pages as results (and not as pages linking to the results). All Links... keys are unused in that case.
	[image: Icon]UserAgent: [string] Custom HTTP user agent string.


Keys for XML/JSON 
Required Keys:
	[image: Icon]ResultsKeyPath: [string] The path to the results in the search engine's output.
	[image: Icon]LinksKeyPath: [string] The path to the links relative to ResultsKeyPath.

Optional Keys:
	[image: Icon]ContentsKeyPath: [string] The path to the contents relative to ResultsKeyPath.
	[image: Icon]DescriptionsKeyPath: [string] The path to the descriptions relative to ResultsKeyPath.
	[image: Icon]TitlesKeyPath: [string] The path to the titles relative to ResultsKeyPath.
	[image: Icon]ThumbnailsKeyPath: [string] The path to the thumbnails relative to ResultsKeyPath.
	[image: Icon]JSONPost: [Dictionary] Sends the content of the dictionary as HTTP POST request. The dictionary can contain nested dictionaries or arrays. string-placeholders, e.g., _agentNumber_ or _agentQuery_, are still replaced.


Localization 
Three identifier keys of a plugin can be localized: Name, Info and Description. Specify the desired key as a dict (dictionary) containing key and string pairs, one per additional language. The key contains the appropriate language code, e.g., en, de, or fr, and the string is the localized text for the specified language.
Example: 

				<key>Name</key>
				
<dict>
				
<key>en</key>
				
<string>DEVONthink Server</string>
				
<key>de</key>
				
<string>DEVONthink-Server</string>
				
</dict>
			
Additionally, the following keys can be localized by adding a suffix for use with language-specific search engines: EngineUrl, EngineNextUrl, KeywordsUrl, and NextLinkName. Language identifiers are: DE, DA, NL, ES, HU, FR, IT, CS, PT, PL, SV, FI, EN, NO, RU, EL, AR, and HE.
Example: 
A URL in the key EngineUrl_DE is used to target the German variant of a search engine.

Notes 
Operator Bitmap: The following table gives you the necessary values for calculating the operator bitmap for the "Operators" key (see above):
	[image: Icon]0 [value: 1]: Supports AND operator
	[image: Icon]1 [value: 2]: Supports OR operator
	[image: Icon]2 [value: 4]: Supports XOR operator
	[image: Icon]3 [value: 8]: Supports NOT operator
	[image: Icon]4 [value: 16]: Supports "" phrases
	[image: Icon]5 [value: 32]: Supports () parenthesis
	[image: Icon]6 [value: 64]: Supports NEAR operator
	[image: Icon]7 [value: 128]: Supports AFTER operator
	[image: Icon]8 [value: 256]: Supports BEFORE operator
	[image: Icon]9 [value: 512]: Supports NEXT operator
	[image: Icon]11 [value: 2048]: Use ANDNOT instead of NOT or -
	[image: Icon]12 [value: 4096]: Convert search term to lower case
	[image: Icon]13 [value: 8192]: Convert search term to upper case
	[image: Icon]14 [value: 16384]: Engine scans for any word by default (not for all words) without an explicit operator
	[image: Icon]15 [value: 32768]: Use AND/NOT instead of +/-
	[image: Icon]16 [value: 65536]: Use | instead of OR
	[image: Icon]17 [value: 131072]: Supports OPT/ operator

LinksStart, et al.: LinksStart, LinksEnd, LinksMatching, and LinksNotMatching are three different ways to specify interesting links of a page. Specify none, some, or all of them depending on the search engine you are accessing. The more you specify, the higher the chances are that the plugin will still work after the structure of the HTML code or the links changed. First DEVONagent Pro retrieves links using LinksStart/LinksEnd, then it filters them using LinksNotMatching, and finally it matches them against LinksMatching.
Link Listings vs Matched Pages: LinksStart/LinksEnd, LinksMatching, and LinksNotMatching are used on pages listing links, e.g., a page of search engine results. Links are always followed on these pages. TextStart/TextEnd, TitleStart/TitleEnd, and DateStart/DateEnd are used on individual web pages, i.e., a matched Wikipedia page. The FollowLinks key/option can be used on these pages.


Troubleshooting
DEVONagent Pro was created with robustness in mind. But any computer hardware and software can write defective data or destroy files. If you have trouble with this application, please refer to the methods below, and also have a look at our FAQ.
DEVONagent Pro behaves irrationally
No software on this planet is bug-free. If an application behaves irrationally, there is a good chance that your have just found a bug. But there may be another: The application package could have become damaged, e.g, during an update or through a bug in an unrelated piece of software on your computer.
If DEVONagent Pro crashes or you have found a bug, please send us a bug report [special link, not enabled in ebook].
Strange Application Behavior 
If something happens like the following
	[image: Icon]menus disappearing or silently refusing to do anything,
	[image: Icon]windows showing graphical artifacts,
	[image: Icon]or applications not opening or opening with strange error messages,

please try to trash the application package. Then empty your web brower's cache, re-download the software in question, and re-install it. In many cases this cures the problem.
If this does not help, try deleting DEVONagent Pro's preferences files located in '~/Library/Preferences' and starting with 'com.devon-technologies.agent'. Access your LIbrary folder by visiting the Go menu in the Finder with the ⌥ key held down.

Strange Behavior of Tabs 
With Zooom/2 installed, tabs in tabbed windows behave stragely, e.g., close by just hovering the cursor over the tab. Another effect of Zooom/2 are scrolling problems. Disabling Zooom/2 solves the problem.


Problems interacting with DEVONthink
DEVONagent Pro uses OS X's Services internally to transfer data to DEVONthink. If DEVONagent Pro beeps when you try to transfer data to DEVONthink, the most likely reason for this problem is that there's something wrong with the Services.
You can use the third party application Service Scrubber to try and modify this behavior; Service Scrubber should allow you to enable/disable services, rename them, or give them new keyboard shortcuts. Some of these modifications, however, can lead to communication problems between DEVONthink and DEVONagent Pro. Restore to the default settings to enable the DEVONagent Pro/DEVONthink link again.

Technology
All commercial DEVONtechnologies applications are based on a proprietary AI technology, with rock-solid database foundation that allow them to manage large numbers of documents or knowledge bits while analyzing them almost instantly at the same time.
General Concept
DEVONtechnology, on which all DEVONtechnologies' applications are built, is a new technology at the very beginning of its development. DEVONtechnologies constantly improves the technology and enhances it for more functionality, efficiency, robustness and flexibility.
Development of the DEVONtechnology is a battle on two main forefronts of information processing technology. DEVONtechnologies is working hard on unifying both the top-down and the bottom-up AI concepts by imitating high-level functions and simulating the basic functionality of natural systems. This leads to highly functional, fast and efficient AI systems that can be used in a great variety of information processing contexts, such as pattern recognition, signal processing and information storage and retrieval.

Features
The DEVONtechnology is a rock-solid foundation suitable for a variety of completely independent applications. Therefore it is ideal for the rapid development of a huge range of new database-, signal-processing- and language-analysis-driven applications. The ability to deal with any kind of digital data makes it extremely flexible.
The size of DEVONtechnology-based databases can, depending on the type of data stored, grow logarithmically and make indexing is completely unnecessary. Also, applications based on the DEVONtechnology improve themselves continuously (the more data they handle, the better the results), are language-independent and iron out any irregularities by applying fuzzy logic.

Structure
The DEVONtechnology consists of a kernel and several layers. Together they perform all the underlying computing, from 'simple' data handling to complex signal processing.
Kernel: The kernel is the foundation for all layers and applications and is responsible for data handling, semantic and associative data processing, signal processing, fast statistic analyses and all fuzzy algorithms. It has to be as fast, flexible, and extensible as possible; it is 64-bit aware and uses a generic, proprietary file format (see above) allowing it to verify and repair low level data consistency, featuring logarithmic growth of the database and logarithmic speed decrease with increasing database size. The DEVONtechnology kernel is Unicode-aware, completely language-independent and self-optimizing and self-organizing.
Layers: The layers form a shell around the kernel and provide high-level functions for the applications built on top of them. The database layer, for example, is used to store and organize data and supports all kinds of relations (1:n, n:1, n:n), hierarchies and freeform databases. No indexing or primary keys are required, strings can be unlimited in size and it's possible at any time to extend the range of pre-defined data types (Boolean, character, float, double, signed, unsigned, string, date, time, blob, color, size, and point). Another layer, the XML layer, makes it easy to handle XML code within the DEVONtechnology; it has a very small overhead, compared to DOM parsers or available XML databases, requires no indexing and supports the tight integration of other databases (and vice versa).

Applications
Some of the most likely applications for the DEVONtechnology are databases (knowledge bases, expert systems, search engines, table-of-content-generators, instant data-mining), intelligent agents, encryption, compression and archiving. Other uses for DEVONtechnology may be chat-bots, context-sensitive help, optical character recognition (OCR), speech analysis, recognition and synthesis, staticstics, thesauri and automatic translations.
In particular, applications dependant on processing human language, either written or spoken, benefit from the flexible technology foundation. So, DEVONtechnologies' main focus in the development of new applications is in these areas: databases, 'intelligent' agents, text and speech analysis, statistics.
Look forward to see a great range of different applications based on the DEVONtechnology. A few have already been announced on the DEVONtechnologies web site: 
		www.devontechnologies.com.

Other Products
Besides DEVONagent Pro, DEVONtechnologies publishes a number of other commercial, shareware, and freeware applications and services that might be helpful for you.
Overview
DEVONtechnologies is focused on developing innovative applications for finding, storing, and organizing information. We make the latest, complex technologies easy to use, and fast.
	[image: Icon]DEVONthink
	[image: Icon]DEVONthink To Go
	[image: Icon]DEVONagent
	[image: Icon]DEVONsphere

We also publish some freeware apps and services.
Newsletter & Community 
Would you like us to keep you informed about updates and new product releases? Visit our blog and subscribe to our free newsletter.
If you have a moment feel free to visit our lively user community. Here, users of all skill levels meet to discuss our applications, talk about our technology, and exchange tips and tricks for DEVONagent Pro & Co.


DEVONthink
Built on core concepts: capture, organize, search and utilize, DEVONthink is your document and information management solution. Efficiently, capture and organize your documents. Find your documents with lightning-fast searches and share those documents to other apps. And use it's built-in AI or access external AI to make connections and queries about your documents. For any project or topic, large or small, DEVONthink can be the center of it all.
	[image: Icon]Learn more about DEVONthink
	[image: Icon]Check your upgrade options if you want to upgrade to a higher edition [special link, not enabled in ebook]


DEVONthink To Go
Carry a library of your documents in the palm of your hand with DEVONthink To Go. Make databases for any need, filling and organizing them for quick access and searches. Create, edit, and annotate documents wherever you are. Use access to external AI to ask questions and gain insight into your documents. And keep your databases in sync with other mobile devices or DEVONthink on your Mac.
Learn more about DEVONthink To Go.

DEVONagent
Your Internet search assistant, DEVONagent Pro is a professional-grade, web-focused search application. Choose where to search, even multiple sites at once, and let it search and filter the results, returning the most relevant matches. Create search sets that will run on a schedule, delivering its findings via email, directly to DEVONthink, or archive them for later. Its related utilities, DEVONagent Express and Lite, run as menubar application for quick and simpler web searches.
Learn more about DEVONagent Pro.

DEVONsphere
Our answer to Spotlight, DEVONsphere Express is your Mac-based search utility. Using a simple but powerful search syntax, locate documents in the locations you choose, even ones in your DEVONthink databases. Also, its unique See Also function detects what's in your frontmost application and tries to find related items for you.
Learn more about DEVONsphere Express.

Needful Things
Search files on your hard disk, watch web cams, create thumbnails, or access all your files and apps from the menu bar. Reformat paragraphs in your favorite word processor or do little calculations anywhere you can type in text. Your network connection lets you down or you want to know if a remote server is still alive or already swimming belly-up? All for free.
Learn more about our freeware apps and services.

Appendix
Glossary
Become familiar with these terms to get the most out of working with DEVONagent Pro.
Keyboard symbols 
	[image: Icon]⌘ The Command key, usually next to the Space bar.
	[image: Icon]⌥ The Option key.
	[image: Icon]⌃ The Control key (usually labeled with "ctrl").
	[image: Icon]⇧ The Shift key.
	[image: Icon]⇥ The Tab key.
	[image: Icon]↩ The Return key.


Interface Elements 
	[image: Icon]Alternative menu item: Some menu items have less frequently used counterparts  that are hidden by default. Press the ⌥Option key when visiting the menu or context menu to make them appear.
	[image: Icon]Context Menu: The menu that appears when you right-click, or click on something with the ⌃ Control key held, something; the context menu gives you access to frequently used commands that deal directly with the clicked object. [Read more...]
	[image: Icon]Plugin: Modules that act as the connector between DEVONagent Pro and search engines. Each plugin is the interface for one or more search engines. In addition, plugins can extend DEVONagent Pro with other functionality, e.g., scanners. DEVONagent Pro knows two types of search engine plugins: Cocoa-based (compiled) plugins, and XML-based plugins that can be created using the Plugin Assistant or using a simple text editor. [Read more...]
	[image: Icon]Scanners: Plugins that act as filters for formal criteria such as 'is a thumbnail gallery' or 'contains links to Word documents'. Scanners are used to refine a search. [Read more...]
	[image: Icon]Search Window: A window in DEVONagent Pro that lets you select a search set, type in a query, start the search run, and view the search results. [Read more...]
	[image: Icon]Topics: A list of words extracted by DEVONagent Pro from search results--generally the most important words in the found documents. Topics can be selected in the search window to focus the visualizer to this topic. [Read more...]
	[image: Icon]Visualizer: A graphic representation of topics and their relationships. The graphic looks like a 'spider web,' with 'bubbles' representing each topic. [Read more...]


Operators, Queries, Search Sets 
	[image: Icon]Boolean operators: Boolean operators are AND, OR, and NOT. They are used to define how words or parts of search terms relate to each other. Example: 'steve AND jobs'. [Read more...]
	[image: Icon]Query: A 'question' sent to one or multiple search engines through a search engine plugin. The query (the question) is written in a formalized style using search words, Boolean operators, and parentheses. [Read more...]
	[image: Icon]Search engine: A computer that keeps an index of documents or information and that can be searched by providing it with a query. Search engines are generally used through a web browser. DEVONagent Pro emulates this human-computer interaction through plugins.
	[image: Icon]Search results: A pool of documents or links to documents, e.g., webpages or PDF documents, returned by a search run.
	[image: Icon]Search run: The process of sending a query to one or multiple search engines.
	[image: Icon]Search set: A set of parameters that defines how DEVONagent Pro conducts a search run. Search sets contain which search engine plugins shall be used, which scanners shall be applied, and what to do with the search results when the search run is completed. [Read more...]
	[image: Icon]Search term: See above: Query. [Read more...]



FAQ
Is DEVONagent Pro an add-on to DEVONthink? 
Although we sell DEVONagent Pro with DEVONthink in a bundle, it is a stand-alone application. Many of our customers use DEVONagent Pro for their research work, but don't necessarily archive the results in DEVONthink.
Can I write my own plug-ins for DEVONagent Pro? 
Sure. The complete documentation on how to make plug-ins for DEVONagent Pro is included in DEVONagent Pro's online documentation.
Can I search my hard disk instead of the Internet? 
Not with the current version of DEVONagent Pro, no. However, our freeware application EasyFind is able to preview found documents and highlight occurrences in file names. And, of course, there is still Spotlight.
How can I search already archived pages 
Open the archive (Tools & Open Archive) and use the search field there.
What advantages does DEVONagent Pro have over searching in my browser? 
The most important advantages over using a search engine in your browser:
	[image: Icon]DEVONagent Pro comes with an innovative visualizer.
	[image: Icon]DEVONagent Pro can query multiple search engines simultaneously.
	[image: Icon]Scanners look for certain kinds of webpages, e.g., pages with webcams, thumbnail galleries, videos, etc.
	[image: Icon]DEVONagent Pro removes duplicate URLs/webpages, advertisements, spam, and HTTP errors.
	[image: Icon]DEVONagent Pro also removes similar pages on demand.
	[image: Icon]DEVONagent Pro scans the current contents of the pages; therefore, it doesn't return wrong results from outdated search engine indexes
	[image: Icon]DEVONagent Pro supports more advanced operators like NEAR, BEFORE, and AFTER
	[image: Icon]DEVONagent Pro can follow promising links automatically.
	[image: Icon]DEVONagent Pro provides more useful and complete summaries in the Pages tab and complete digests based on selected/entered topics or the used query.
	[image: Icon]You can easily find similar results ("See Also"), archive results or transfer them to DEVONthink.

Why does DEVONagent Pro crash when displaying PDFs? 
DEVONagent Pro can crash when trying to display PDF files on Macs with Adobe Acrobat installed. Acrobat's browser plugin is incompatible to the web browser engine of both OS X and DEVONagent Pro. Remove the Acrobat plugin from "/Library/Internet Plug-Ins" and everything should work as advertised.
Why does DEVONagent Pro crash when I open a browser window or an archived page? 
DEVONagent Pro uses Apple's WebKit as its browser engine. When WebKit crashes it draws DEVONagent Pro with it into the abyss and there is little we can do about it. So most DEVONagent Pro crashes related to browsing are, in fact, WebKit crashes. Please send us your crash log (in ~/Library/Logs/CrashReporter/) if you want to know what happened.
How do I completely uninstall DEVONagent Pro? 
To completely remove DEVONagent Pro from your Mac, see the instructions in the Read Me.

List of Search Sets
Search sets are sets of parameters and options that control which search engines are used for a search run, which sites are crawled directly, what is filtered, and what is done with the returned results. DEVONagent Pro comes with a number of example search sets to get you started:
	[image: Icon]Apple (Feeds): Crawls some RSS feeds (Downloads, PR and Hot News) provided by Apple.
	[image: Icon]Marketing: Crawls more than 200 IT and Macintosh related news sites and feeds (the default query looks for news related to DEVONtechnologies).
	[image: Icon]Mac > Latest Software: Crawls some software trackers and directories for new releases.
	[image: Icon]Mac > Latest News: Crawls the most popular Macintosh news sites and feeds.
	[image: Icon]Web (Scanner) > Movies: Queries the Web plugin and scans the results for linked movies and videos.
	[image: Icon]Web (Scanner) > Thumbnail Galleries: Queries the Web plugin and scans the results for thumbnail galleries.
	[image: Icon]Web (Scanner) > Downloads: Queries the Web plugin and scans the results for downloadable archives.
	[image: Icon]Web > Deep: Queries Bing, Brave, Ecosida, and Yahoo plugins (up to 100 results per plugin).
	[image: Icon]Web > Deeper: Queries Bing, Brave, Ecosida, and Yahoo plugins (up to 100 results per plugin) and follows links (one level).
	[image: Icon]Web > Deepest: Queries Bing, Brave, Ecosida, and Yahoo plugins (up to 100 results per plugin) and follows links (maximum level).
	[image: Icon]Web > Express: Queries the Web plugin (up to 60 results) in express mode (no filtering).
	[image: Icon]Web > Fast: Queries the Web plugin (up to 100 results), but does not follow links to return results as soon as possible.

Start with the Web > Fast search set for your first search runs, then use the Search Sets window to make your own or adapt an existing one for your requirements.

List of Plugins
Technically, plugins are collections of URLs and procedures that DEVONagent Pro uses to access search engines on the Web. They are either written in Cocoa or in human-readable XML (plain text with special syntax). In addition to simple HTML queries, DEVONagent Pro also supports and analyzes Atom, RSS, and JSON feeds.
In the list below, you will find the associated quick search keywords in brackets. You use quick search keywords to send a query to a plugin directly from the address bar of a web browser window. You can change the quick search keyword in the Plugins & Scanners panel.
Note:
 Some sites need a valid log-in. If you want to query these sites with a plugin, you need to enable cookies and manually log in with your web browser in advance. When you use DEVONagent Pro, the websites then will recognize you as a returning user. You will find a note in the plugin description if a site requires a log-in.
Search 
Note:
 DEVONagent Pro presents this category separately in its menu, above the other plugins to make them more easily accessible.
	[image: Icon]Baidu: Searches the web using Baidu.
	[image: Icon]Bing: Searches the web using Bing.
	[image: Icon]Brave Search: Searches the web using the Brave Search engine.
	[image: Icon]DuckDuckGo: Searches the web using DuckDuckGo, a search engine that claims that it doesn't track its users and delivers unbiased results (see also: filter bubble).
	[image: Icon]Ecosia: Searches the web using Ecosia, a search engine that claims to use part of its advertising revenue for planting trees.
	[image: Icon]Web: Searches the web using Bing, Brave Search , Ecosia, and Yahoo. Depending on the system language, DEVONagent Pro also uses local search engines or local variants.
	[image: Icon]Yahoo: Searches the web using Yahoo, one of the three major search engines.


Apple 
	[image: Icon]App Store: Searches Apple's App Store.
	[image: Icon]Developer Connection: Searches the Apple Developer Connection database, the number one source for OS X developers.
	[image: Icon]Knowledge Base: Searches the Apple Knowledge Base, the #1 resource for finding technical information about Mac computers, Mac OS and Apple software.
	[image: Icon]Macintosh News: Scans major Macintosh news sites, namely Macworld, MacCentral, Macintouch, and MacNN.Use this plugin to stay up-to-date about everything Macintosh.
	[image: Icon]MacUpdate: Searches for OS X software using Macupdate. MacUpdate watches for the latest Macintosh software updates and visits over more than 800 websites a day, looking for version changes to software titles not submitted by developers.


Browsers 
	[image: Icon]All Cached Pages: Scans all pages cached by earlier search runs. Use this to include already scanned pages again in a new search.
	[image: Icon]Bookmarks: Scans all websites bookmarked in DEVONagent, Safari, OmniWeb, Camino, Chrome, or Firefoxfor the search query. You can use this plugin to create your private mini-web with bookmarks and search only this collection.
	[image: Icon]DEVONthink databases: Searches all web sites bookmarkes in the currently opened DEVONthink databases.
	[image: Icon]DEVONthink server: Searches shared DEVONthink Pro Office databases through the local web server. DEVONthink Pro Office has to be running and web sharing started by the same user.
	[image: Icon]History: Scans the pages you have visited recently with Safari or DEVONagent Pro for the search query. This is useful for searching for something you remember you have seen recently, but you cannot remember where.


Computer Science 
	[image: Icon]ACM Digital Library: Searches the digital library of the Association for Computing Machinery.
	[image: Icon]Apple Cocoa-Dev: Searches Apple's cocoa-dev mailing list. This is very useful if you do OS X software development.
	[image: Icon]Citeseer: Searches the CiteSeer library. Citeseer is a scientific literature digital library and search engine that focuses primarily on the literature in computer and information science.
	[image: Icon]Cocoabuilder: Searches Apple & Omnigroup Cocoa mailing lists using Cocoabuilder. Very useful if you do OS X software development.
	[image: Icon]GitHub Code Search: Searches GitHub for code.
	[image: Icon]Openhub Search: Searches for open source code examples and projects using Open Hub.


Dictionaries 
	[image: Icon]Acronym Finder: Searches Acronym Finder, the world's largest and most accurate dictionary of acronyms, abbreviations and initialisms.
	[image: Icon]Dictionaries: Looks for word definitions in online dictionaries, namely Reference.com and  Hyperdictionary.
	[image: Icon]Infoplease: Searches Infoplease, a reference source that combines the contents of an encyclopedia, a dictionary, an atlas, and several almanacs with statistics, facts and historical records.
	[image: Icon]Onelook: Searches for word definitions or translations using Onelook. Onelook is a search engine that provides access to web-based dictionaries that define or translate words.
	[image: Icon]Wiktionary: Looks for word definitions in the online dictionary Wiktionary. Wiktionary is a free multilingual dictionary and thesaurus that's being written collaboratively. Anybody can edit any article and a record of changes is kept. This plugin is localized and searches in the selected language.


Government 
	[image: Icon]USA.gov: Searches for U.S. government information using FirstGov.gov. FirstGov.gov is the official U.S. gateway to all government information, with millions of webpages from federal and state governments, the District of Columbia and U.S. territories.


Images & Videos 
	[image: Icon]Images: Finds images using Yahoo's image search. Whatever image you are looking for, if it's on the Internet, you should be able to find it.
	[image: Icon]Picsearch: Searches for pictures using Picsearch. Picsearch is a search engine specialized in creating a searchable index of images.


Legal 
	[image: Icon]EUR-Lex: Searches EUR-Lex for law documents and other public documents of the European Union. The contents of the site amount to more than 2.8 million documents with texts dating back to 1951. The database is updated daily and every year around 12,000 documents are added.
	[image: Icon]FindLaw: Searches for legal materials using FindLaw. FindLaw is the highest-trafficked legal website, providing a comprehensive set of legal resources on the Internet for legal professionals, businesses, students and individuals.
	[image: Icon]Lexis Web: Searches for legal materials using Lexis. LexisNexis provides customers with access to billions of searchable documents and records from more than 45,000 legal, news, and business sources.


Medical 
	[image: Icon]FDA: Searches for material on the website of the U.S. Food and Drug Administration. The index is updated every night as many FDA documents are time sensitive.
	[image: Icon]MedlinePlus: Searches for health-related materials using MedlinePlus. MedlinePlus brings together authoritative information from the National Library of Medicie (NLM), the National Institutes of Health (NIH) and other government agencies and health-related organizations.
	[image: Icon]MyHealthfinder: Searches for health-related materials using Healthfinder. Healthfinder is a gateway to selected consumer health and human services information resources provided by government agencies and other organizations.
	[image: Icon]PubMed: Searches the PubMed bibliographic database. PubMed provides access to bibliographic information that includes MEDLINE and OLDMEDLINE, as well as out-of-scope citations, citations that precede the date that a journal was selected for MEDLINE indexing, and some additional life science journals that submit full text to PubMedCentral and receive a qualitative review by the NLM.
	[image: Icon]WebMD: Searches for health-related materials using WebMD. WebMD provides valuable health information, tools for managing your health and support to those who seek information.


News 
	[image: Icon]BBC News: Searches for news on BBC News.
	[image: Icon]Reuters: Searches for news on the Reuters news database. Reuters is a global information company providing information tailored for professionals in the financial services, media, and corporate markets.
	[image: Icon]World News Network: Searches for news on the World News Network. World News Network ranks as one of the top sites for world news on the Internet. It includes more than 3,000 sites and covers 24 languages, categorized by geography and subject.
	[image: Icon]Yahoo News: Searches for news on Yahoo News. Yahoo uses its own search engine to scan important news websites and automatically compile a news portal using the found data.


References 
	[image: Icon]British Library: Searches the British Library.
	[image: Icon]Gutenberg.de: Searches for literature in the German-language Project Gutenberg database of free ebooks.
	[image: Icon]Gutenberg.org: Searches for literature in the English-language Project Gutenberg database of free ebooks.
	[image: Icon]Highbeam: Searches for articles on Highbeam Research. HighBeam regards itself as the premier online research tool for business and academic use, with more than 80 million articles culled from the archives of over 6,500 newspapers, magazines, journals, and other publications.
	[image: Icon]Internet Public Library: Searches for literature in the The Internet Public Library. The Internet Public Library is a public service organization and a learning and teaching online environment at the University of Michigan School of Information.
	[image: Icon]JSTOR: Searches for articles on JSTOR. With more than a thousand academic journals and over 1 million images, letters, and other primary sources, JSTOR claims to be one of the world's most trusted sources for academic content.
	[image: Icon]Philosophy: Searches for literature in the Stanford Encyclopedia of Philosophy.The Stanford Encyclopedia of Philosophy is maintained and kept up-to-date by an expert or group of experts in the field.
	[image: Icon]Poetry: Searches for English poetry using the Electronic Poetry Center, founded by Loss Pequeno Glazier and Charles Bernstein.
	[image: Icon]SEC: Searches the EDGAR database of the SEC.
	[image: Icon]Wikipedia: Searches for articles in the free online encylopedia Wikipedia. The content of Wikipedia is free and is written collaboratively by people from all around the world. Begun in 2001, Wikipedia has grown rapidly into the largest reference website on the Internet. This plugin is localized and searches in the selected language.


Science 
	[image: Icon]American Chemical Society: Searches for materials on the American Chemical Society (ACS) website. The American Chemical Society is a self-governed individual membership organization that consists of more than 158,000 members at all degree levels and in all fields of chemistry.
	[image: Icon]IngentaConnect: Searches online journals using IngentaConnect. IngentaConnect publishes scholarly and professional journals in all subject areas. It supports and produces more than 3,000 online journals.


Shopping 
	[image: Icon]Amazon: Searches for articles on Amazon. Chooses Amazon in the USA, Germany, or France depending on the system language.


Social Networking 
	[image: Icon]Facebook profiles: Searches for profiles on Facebook.



List of Scanners
Scanners do not query search engines, but rather filter webpages that do not match their criteria. For example, scanners can filter all pages that do not contain links to images or Office documents, pages that do not contain email addresses, or pages that have no embedded images. You can also use scanners to restrict search runs to Atom/RSS/JSON feeds, pages with linked documents, or to thumbnail galleries. Scanners filter out all pages that do not match.
Also, scanners are used by the sidebar of web browser windows to filter certain elements and display them lists, e.g. links, images, or news feeds.
By default, DEVONagent Pro comes with the following scanners that you can use in search sets.
	[image: Icon]All Links: Lists all links of a page, e.g., those found by a secondary query.
	[image: Icon]Atom, RSS & JSON Feeds: Looks for linked Atom, RSS, and JSON news feeds.
	[image: Icon]Audio files: Looks for linked or embeddedaudio files and audio streams.
	[image: Icon]Code: Looks for code snippets.
	[image: Icon]Email Addresses: Looks for email addresses and recognizes even non-linked and scrambled addresses like "info at devon-technologies dot com".
	[image: Icon]Embedded Images: Lists all images of the page, e.g., those found by a secondary query.
	[image: Icon]Linked BibTeX & LaTeX Files: Looks for linked BibTeX and LaTeX files.
	[image: Icon]Linked Binary Files: Looks for linked downloadable compressed archives and disk images.
	[image: Icon]Linked Documents: Looks for linked PDF, PostScript, OpenOffice, StarOffice, WordPerfect, Microsoft Word, Microsoft PowerPoint, EPUB, Kindle, or text documents.
	[image: Icon]Linked Scripts: Looks for linked AppleScript scripts.
	[image: Icon]Linked Spreadsheets: Looks for linked spreadsheet files (XMLSS, Microsoft Excel, CSV, TSV).
	[image: Icon]Linked Vcard files: Looks for linked business card files (.vcf).
	[image: Icon]Recipies: Looks for cooking recipies.
	[image: Icon]Thumbnail Galleries: Looks for images in an image gallery, but lets pass all pages containing (usually smaller) images linked to (usually larger) image files, a.k.a. thumbnail galleries.
	[image: Icon]Twitter Accounts: Looks for links referencing unique Twitter IDs.
	[image: Icon]Video Files: Looks for linked or embedded video files and streams.
	[image: Icon]Wallpapers: Looks for desktop background pictures.
	[image: Icon]Webcams: Looks for web cams and live streams.


Log message codes
DEVONagent Pro logs all pages filtered out in the log, together with a short code describing why the page was filtered. Use the log tab of search windows to find out which pages have been dropped and for what reason.
HTTP Error Codes 
These error codes are standard HTTP error codes delivered directly from web server that DEVONagent Pro asked for a file:
	[image: Icon]204: No response
	[image: Icon]301: Moved permanently
	[image: Icon]302: Moved temporarily
	[image: Icon]401: Authorization required
	[image: Icon]403: Forbidden
	[image: Icon]404: Page not found
	[image: Icon]408: Request timeout
	[image: Icon]410: Gone
	[image: Icon]500: Internal server error
	[image: Icon]501: Not implemented
	[image: Icon]502: Service temporarily overloaded
	[image: Icon]503: Gateway timeout
	[image: Icon]522: Connection timed out

Wikipedia has a complete list of all possible HTTP error codes.

DEVONagent Pro Error Descriptions 
These errors appear in the log when communication problems with the web server occurred, or, more likely, when DEVONagent Pro filtered the page out due to search strategy or user-defined settings.
	[image: Icon]Advertisements: Link or frame probably contains only advertisement or banners
	[image: Icon]Archived: Identical page has already been archived (if "Archived Pages"filter is activated)
	[image: Icon]Disabled format: Page isn't in a suitable format
	[image: Icon]Disallowed: Page couldn't be downloaded due to permissions
	[image: Icon]Duplicate: Identical page already found
	[image: Icon]Excluded: URL or domain excluded by the user
	[image: Icon]Failed: Search engine could not be reached
	[image: Icon]Filtered by scanner: Page did not pass the selected scanner
	[image: Icon]Host not found: Website not found
	[image: Icon]Identical: Identical page with different URL already found
	[image: Icon]Incomplete: Download could not be completed
	[image: Icon]Junk: Page contains almost no useful information (if the article filter filter is activated)
	[image: Icon]Language: Page does not match the language selected in the language filter
	[image: Icon]Links: x of y: Pages delivered as a result by a search engine. Numbers indicate used links vs. returned links. If the number of used links is lower than the returned one, then either another search engine already returned the same link or the host is blocked.
	[image: Icon]Lookup failure: Domain of website not found
	[image: Icon]No content: Page does not contain any text
	[image: Icon]No match: Page does not match the query term
	[image: Icon]Only links: Only links matching the query term found (if Follow Links is activated)
	[image: Icon]SPAM: Page tried to fool search engines, but does not match the query term without those tricks
	[image: Icon]Similar: Similar page (different layout but similar text) with different URL already found (if Similar Pages is activated)
	[image: Icon]Skipped: Domain was skipped because it matches one or more entries in the list of unwanted sites
	[image: Icon]Timeout: Web server didn't respond in time
	[image: Icon]Too big: Page is larger than the maximum size defined in the preferences
	[image: Icon]Unknown data: No HTML or text content
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